summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2013-01-17 10:57:50 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2013-01-17 10:57:50 +0000
commit0da668b6fd056de856adce597d743e078a6edd23 (patch)
treea000249bf2ebb9bc549b5cf5c5ecc9430d4d8020 /sys-devel/parity
parentSupport newer libcdio-paranoia (diff)
downloadgentoo-2-0da668b6fd056de856adce597d743e078a6edd23.tar.gz
gentoo-2-0da668b6fd056de856adce597d743e078a6edd23.tar.bz2
gentoo-2-0da668b6fd056de856adce597d743e078a6edd23.zip
Revbump, bug#450574, with patch to not abort on fatal exception when debugger is present. No point in having the x86-winnt keyword. Prevent live keywords from ekeyword.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'sys-devel/parity')
-rw-r--r--sys-devel/parity/ChangeLog12
-rw-r--r--sys-devel/parity/files/parity-1.2.6-debugging.patch17
-rw-r--r--sys-devel/parity/parity-1.2.6.ebuild63
-rw-r--r--sys-devel/parity/parity-9999.ebuild8
4 files changed, 94 insertions, 6 deletions
diff --git a/sys-devel/parity/ChangeLog b/sys-devel/parity/ChangeLog
index 8f8410456183..1918c6a7470e 100644
--- a/sys-devel/parity/ChangeLog
+++ b/sys-devel/parity/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/parity
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/ChangeLog,v 1.3 2012/04/16 08:40:47 haubi Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/ChangeLog,v 1.4 2013/01/17 10:57:50 haubi Exp $
+
+*parity-1.2.6 (17 Jan 2013)
+
+ 17 Jan 2013; Michael Haubenwallner <haubi@gentoo.org> +parity-1.2.6.ebuild,
+ +files/parity-1.2.6-debugging.patch, parity-9999.ebuild:
+ Revbump, bug#450574, with patch to not abort on fatal exception when debugger
+ is present. No point in having the x86-winnt keyword. Prevent live keywords
+ from ekeyword.
16 Apr 2012; Michael Haubenwallner <haubi@gentoo.org> metadata.xml:
add myself as co-maintainer
diff --git a/sys-devel/parity/files/parity-1.2.6-debugging.patch b/sys-devel/parity/files/parity-1.2.6-debugging.patch
new file mode 100644
index 000000000000..709f46ee9734
--- /dev/null
+++ b/sys-devel/parity/files/parity-1.2.6-debugging.patch
@@ -0,0 +1,17 @@
+--- parity.runtime/diagnose.c.orig 2012-09-28 17:12:54 +0200
++++ parity.runtime/diagnose.c 2012-09-28 17:11:14 +0200
+@@ -745,9 +745,11 @@
+ CloseHandle(hCore);
+ }
+
+- // abort on fatal exceptions
+- TerminateProcess(GetCurrentProcess(), 1);
+- ExitProcess(1);
++ if (!IsDebuggerPresent()) {
++ // abort on fatal exceptions
++ TerminateProcess(GetCurrentProcess(), 1);
++ ExitProcess(1);
++ }
+ return EXCEPTION_CONTINUE_SEARCH;
+ }
+
diff --git a/sys-devel/parity/parity-1.2.6.ebuild b/sys-devel/parity/parity-1.2.6.ebuild
new file mode 100644
index 000000000000..54c54ff53917
--- /dev/null
+++ b/sys-devel/parity/parity-1.2.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/parity-1.2.6.ebuild,v 1.1 2013/01/17 10:57:50 haubi Exp $
+
+EAPI=4
+
+inherit eutils
+
+if [[ ${PV} == 9999 ]]; then
+ inherit subversion
+ ESVN_REPO_URI="https://parity.svn.sf.net/svnroot/parity/trunk"
+ ESVN_BOOTSTRAP="confix --bootstrap"
+ ESVN_PROJECT="${PN}"
+ : ${KEYWORDS=""}
+
+ DEPEND="dev-util/confix"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86-interix"
+fi
+DESCRIPTION="An Interix to native Win32 Cross-Compiler Tool (requires Visual Studio)."
+HOMEPAGE="http://www.sourceforge.net/projects/parity/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ if [ -z "${MSSDK}" ]; then
+ einfo "NOTE: When using Visual Studio 2008, the Platform SDK is no longer"
+ einfo "installed alongside with the other components, but has it's own"
+ einfo "root directory, most likely something like this:"
+ einfo ""
+ einfo " C:\\Program Files\\Microsoft SDKs\\Windows\\v6.0A"
+ einfo ""
+ einfo "To make parity find it's paths correctly, please set MSSDK to the"
+ einfo "value correspoding to the above example for your system."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debugging.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # create i586-pc-winnt*-g[++|cc|..] links..
+ local exeext=
+
+ [[ -f ${ED}/usr/bin/parity.gnu.gcc.exe ]] && exeext=.exe
+
+ # create cross compiler syms
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-gcc
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-c++
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-g++
+ dosym /usr/bin/parity.gnu.ld${exeext} /usr/bin/i586-pc-winnt$(uname -r)-ld
+
+ # we don't need the header files installed by parity... private
+ # header files are supported with a patch from 2.1.0-r1 onwards,
+ # so they won't be there anymore, but -f does the job in any case.
+ rm -f "${ED}"/usr/include/*.h
+}
diff --git a/sys-devel/parity/parity-9999.ebuild b/sys-devel/parity/parity-9999.ebuild
index d1ee5b12ea5f..7fbf94c95ef7 100644
--- a/sys-devel/parity/parity-9999.ebuild
+++ b/sys-devel/parity/parity-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/parity-9999.ebuild,v 1.3 2011/08/10 20:31:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/parity-9999.ebuild,v 1.4 2013/01/17 10:57:50 haubi Exp $
EAPI=4
@@ -9,12 +9,12 @@ if [[ ${PV} == 9999 ]]; then
ESVN_REPO_URI="https://parity.svn.sf.net/svnroot/parity/trunk"
ESVN_BOOTSTRAP="confix --bootstrap"
ESVN_PROJECT="${PN}"
- KEYWORDS=""
+ : ${KEYWORDS=""}
DEPEND="dev-util/confix"
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
- KEYWORDS="~x86-interix ~x86-winnt"
+ KEYWORDS="~x86-interix"
fi
DESCRIPTION="An Interix to native Win32 Cross-Compiler Tool (requires Visual Studio)."
HOMEPAGE="http://www.sourceforge.net/projects/parity/"