summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-05-15 22:12:05 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-05-15 22:12:05 +0000
commit193bc019293bc335b0ba646d5ab6245a8ef451f9 (patch)
treed7c8a7ca4e73bc510023e8eae18fbb4d143fa1d2 /sys-devel/patch/patch-2.5.4-r5.ebuild
parentcleanup (diff)
downloadgentoo-2-193bc019293bc335b0ba646d5ab6245a8ef451f9.tar.gz
gentoo-2-193bc019293bc335b0ba646d5ab6245a8ef451f9.tar.bz2
gentoo-2-193bc019293bc335b0ba646d5ab6245a8ef451f9.zip
added IUSE; some suggested changes from agriffis: don't export CFLAGS; that's done automatically, use emake, use einstall; other small cleanups
Diffstat (limited to 'sys-devel/patch/patch-2.5.4-r5.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.4-r5.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/sys-devel/patch/patch-2.5.4-r5.ebuild b/sys-devel/patch/patch-2.5.4-r5.ebuild
index 7fcf55641549..922069164637 100644
--- a/sys-devel/patch/patch-2.5.4-r5.ebuild
+++ b/sys-devel/patch/patch-2.5.4-r5.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r5.ebuild,v 1.1 2003/05/14 02:24:33 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r5.ebuild,v 1.2 2003/05/15 22:12:00 msterret Exp $
+
+IUSE="build"
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Utility to apply diffs to files"
-SRC_URI="ftp://ftp.gnu.org/gnu/patch/${A}"
+SRC_URI="ftp://ftp.gnu.org/gnu/patch/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
DEPEND="virtual/glibc"
LICENSE="GPL-2"
@@ -13,24 +14,21 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
src_compile() {
- CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"; export CFLAGS
+ CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- if [ -z "`use static`" ]
- then
- make ${MAKEOPTS} || die "make failed"
- else
- make ${MAKEOPTS} LDFLAGS=-static || die "make failed"
- fi
+ if [ -z "`use static`" ]; then
+ emake || die "emake failed"
+ else
+ emake LDFLAGS=-static || die "emake failed"
+ fi
}
src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || \
- die "make install failed"
- if [ -z "`use build`" ]
- then
- dodoc AUTHORS COPYING ChangeLog NEWS README
- else
- rm -rf ${D}/usr/share/man
- fi
+ einstall
+ if [ -z "`use build`" ]; then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
}