summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-05-14 02:24:33 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-05-14 02:24:33 +0000
commit7ca1b836ba2ca104f106d2266230aa3e0c2287aa (patch)
tree5caa5d1763f687ff1680f6200bc8edee3d887de5 /sys-devel/patch/patch-2.5.4-r5.ebuild
parentbumped version to 4.0s final (diff)
downloadgentoo-2-7ca1b836ba2ca104f106d2266230aa3e0c2287aa.tar.gz
gentoo-2-7ca1b836ba2ca104f106d2266230aa3e0c2287aa.tar.bz2
gentoo-2-7ca1b836ba2ca104f106d2266230aa3e0c2287aa.zip
New ebuild for patch that uses || die instead of try.
Diffstat (limited to 'sys-devel/patch/patch-2.5.4-r5.ebuild')
-rw-r--r--sys-devel/patch/patch-2.5.4-r5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/patch/patch-2.5.4-r5.ebuild b/sys-devel/patch/patch-2.5.4-r5.ebuild
new file mode 100644
index 000000000000..7fcf55641549
--- /dev/null
+++ b/sys-devel/patch/patch-2.5.4-r5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r5.ebuild,v 1.1 2003/05/14 02:24:33 msterret Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility to apply diffs to files"
+SRC_URI="ftp://ftp.gnu.org/gnu/patch/${A}"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+DEPEND="virtual/glibc"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+src_compile() {
+ CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"; export CFLAGS
+ ac_cv_sys_long_file_names=yes \
+ ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ if [ -z "`use static`" ]
+ then
+ make ${MAKEOPTS} || die "make failed"
+ else
+ make ${MAKEOPTS} LDFLAGS=-static || die "make failed"
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || \
+ die "make install failed"
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}