summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-20 02:46:28 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-20 02:46:28 +0000
commit6439cb19df158dff25e4ef142065b3e17d83e428 (patch)
tree092d0f8bd3c82c7e075a899827b7f444d61151a7 /sys-devel/smatch
parentBeta channel bump. (diff)
downloadgentoo-2-6439cb19df158dff25e4ef142065b3e17d83e428.tar.gz
gentoo-2-6439cb19df158dff25e4ef142065b3e17d83e428.tar.bz2
gentoo-2-6439cb19df158dff25e4ef142065b3e17d83e428.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel/smatch')
-rw-r--r--sys-devel/smatch/ChangeLog11
-rw-r--r--sys-devel/smatch/smatch-1.57.ebuild54
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild19
3 files changed, 74 insertions, 10 deletions
diff --git a/sys-devel/smatch/ChangeLog b/sys-devel/smatch/ChangeLog
index 7abeb1947fd5..32a3ff188a41 100644
--- a/sys-devel/smatch/ChangeLog
+++ b/sys-devel/smatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/smatch
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/ChangeLog,v 1.2 2011/09/21 08:38:29 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/ChangeLog,v 1.3 2012/12/20 02:46:28 vapier Exp $
+
+*smatch-1.57 (20 Dec 2012)
+
+ 20 Dec 2012; Mike Frysinger <vapier@gentoo.org> +smatch-1.57.ebuild,
+ smatch-9999.ebuild:
+ Version bump.
21 Sep 2011; Michał Górny <mgorny@gentoo.org> smatch-9999.ebuild:
Migrate to git-2.
@@ -10,4 +16,3 @@
08 Sep 2011; Mike Frysinger <vapier@gentoo.org> +smatch-9999.ebuild,
+metadata.xml:
Initial ebuild.
-
diff --git a/sys-devel/smatch/smatch-1.57.ebuild b/sys-devel/smatch/smatch-1.57.ebuild
new file mode 100644
index 000000000000..b73a6576262f
--- /dev/null
+++ b/sys-devel/smatch/smatch-1.57.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-1.57.ebuild,v 1.1 2012/12/20 02:46:28 vapier Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+ http://repo.or.cz/r/${PN}.git"
+ inherit git-2
+fi
+
+DESCRIPTION="static analysis tool for C"
+HOMEPAGE="http://smatch.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ # The repo.or.cz site does not produce stable tarballs,
+ # so we have to cache our own copy of the snapshot.
+ #SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="mirror://gentoo/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/sqlite"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ Makefile || die
+}
+
+src_compile() {
+ emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch
+}
+
+src_install() {
+ # default install target installs a lot of sparse cruft
+ dobin smatch
+ insinto /usr/share/smatch/smatch_data
+ doins smatch_data/*
+ dodoc FAQ README
+}
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
index bde661fa5621..aec2144d3154 100644
--- a/sys-devel/smatch/smatch-9999.ebuild
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.2 2011/09/21 08:38:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.3 2012/12/20 02:46:28 vapier Exp $
-EAPI="2"
+EAPI="4"
inherit multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -18,7 +18,10 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
#KEYWORDS=""
else
- SRC_URI=""
+ # The repo.or.cz site does not produce stable tarballs,
+ # so we have to cache our own copy of the snapshot.
+ #SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="mirror://gentoo/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -29,6 +32,8 @@ IUSE=""
RDEPEND="dev-db/sqlite"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}
+
src_prepare() {
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
@@ -37,13 +42,13 @@ src_prepare() {
}
src_compile() {
- emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch || die
+ emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch
}
src_install() {
# default install target installs a lot of sparse cruft
- dobin smatch || die
+ dobin smatch
insinto /usr/share/smatch/smatch_data
- doins smatch_data/* || die
+ doins smatch_data/*
dodoc FAQ README
}