summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-31 16:22:00 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-31 16:22:00 +0000
commit109aeaab25eb3f95aafd2d682531adc2a0839959 (patch)
tree1039a038965bd59d945e0be285c69d6dda8864a1 /sys-devel
parentStable for x86, wrt bug #488630 (diff)
downloadgentoo-2-109aeaab25eb3f95aafd2d682531adc2a0839959.tar.gz
gentoo-2-109aeaab25eb3f95aafd2d682531adc2a0839959.tar.bz2
gentoo-2-109aeaab25eb3f95aafd2d682531adc2a0839959.zip
Update the Gentoo patch. Use multilib_build_binaries per bug #489586.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-3.4-gentoo-install.patch10
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
3 files changed, 13 insertions, 9 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 160bd9842844..6bf7b7ce575e 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.142 2013/10/14 16:39:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.143 2013/10/31 16:22:00 mgorny Exp $
+
+ 31 Oct 2013; Michał Górny <mgorny@gentoo.org>
+ files/llvm-3.4-gentoo-install.patch, llvm-9999.ebuild:
+ Update the Gentoo patch. Use multilib_build_binaries per bug #489586.
14 Oct 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild, metadata.xml:
Clean up the deps & configure call. Add USE=ncurses to control terminfo use.
diff --git a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch b/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch
index 41f5070561f8..2c7bcafc875a 100644
--- a/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch
+++ b/sys-devel/llvm/files/llvm-3.4-gentoo-install.patch
@@ -1,7 +1,7 @@
-From f06a30b4412a99c083debf2621c3edb538a6b444 Mon Sep 17 00:00:00 2001
+From b8846d389ff5e2b768a114f752cf39788accba26 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Mon, 19 Aug 2013 13:22:46 +0200
-Subject: [PATCH 1/2] gentoo install fixes
+Subject: [PATCH] gentoo install fixes
---
Makefile.config.in | 6 +++---
@@ -32,13 +32,13 @@ index dcca45f..e75ae2e 100644
PROJ_infodir := $(PROJ_prefix)/info
PROJ_mandir := $(PROJ_prefix)/share/man
diff --git a/Makefile.rules b/Makefile.rules
-index ed7e0e9..d3a18ca 100644
+index e53598b..217f754 100644
--- a/Makefile.rules
+++ b/Makefile.rules
@@ -275,7 +275,7 @@ ifeq ($(ENABLE_OPTIMIZED),1)
BuildMode := Release
# Don't use -fomit-frame-pointer on Darwin or FreeBSD.
- ifneq ($(HOST_OS), $(filter $(HOST_OS), Cygwin Darwin FreeBSD GNU/kFreeBSD))
+ ifneq ($(HOST_OS), $(filter $(HOST_OS), Cygwin Darwin DragonFly FreeBSD GNU/kFreeBSD))
- OmitFramePointer := -fomit-frame-pointer
+ OmitFramePointer :=
endif
@@ -133,5 +133,5 @@ index 268b7bc..e7674f9 100644
include $(LEVEL)/Makefile.common
--
-1.8.3.2
+1.8.4.2
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 041f974e4d23..45715fe8b54d 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.57 2013/10/14 16:39:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.58 2013/10/31 16:22:00 mgorny Exp $
EAPI=5
@@ -204,7 +204,7 @@ multilib_src_configure() {
fi
fi
- if multilib_is_native_abi && use gold; then
+ if multilib_build_binaries && use gold; then
CONF_FLAGS="${CONF_FLAGS} --with-binutils-include=${EPREFIX}/usr/include/"
fi
if multilib_is_native_abi && use ocaml; then
@@ -282,7 +282,7 @@ multilib_src_install() {
"${ED}"/usr/bin/* || die
fi
- if multilib_is_native_abi; then
+ if multilib_build_binaries; then
# Move files back.
if path_exists -o "${ED}"/tmp/llvm-config.*; then
mv "${ED}"/tmp/llvm-config.* "${ED}"/usr/bin || die