summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-02-28 19:35:04 +0000
committerFabian Groffen <grobian@gentoo.org>2014-02-28 19:35:04 +0000
commit1354f4caf32bad2622896a3739fce1ba3b3c9a4b (patch)
tree6daf2ffc2393b1c3776fbb1eaa010f89822328fc /sys-devel
parentAdd linux/musl/mips and linux/musl/mips/mipsel (diff)
downloadgentoo-2-1354f4caf32bad2622896a3739fce1ba3b3c9a4b.tar.gz
gentoo-2-1354f4caf32bad2622896a3739fce1ba3b3c9a4b.tar.bz2
gentoo-2-1354f4caf32bad2622896a3739fce1ba3b3c9a4b.zip
Do not override CC, but rather append what we need in 64-bits mode
(Portage version: 2.2.8-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-apple/ChangeLog9
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild8
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-devel/gcc-apple/ChangeLog b/sys-devel/gcc-apple/ChangeLog
index ab9df901cfd8..986e5739871b 100644
--- a/sys-devel/gcc-apple/ChangeLog
+++ b/sys-devel/gcc-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc-apple
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.23 2012/06/11 18:26:50 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/ChangeLog,v 1.24 2014/02/28 19:35:04 grobian Exp $
+
+ 28 Feb 2014; Fabian Groffen <grobian@gentoo.org>
+ gcc-apple-4.2.1_p5666-r1.ebuild:
+ Do not override CC, but rather append what we need in 64-bits mode
11 Jun 2012; Fabian Groffen <grobian@gentoo.org>
-files/gcc-apple-4.2.1-gfortran.patch,
@@ -335,4 +339,3 @@
New organisation of Apple's GCC ebuilds. Ebuilds now carry the GCC
version in their name. All ebuilds rely on gcc-config, and appropriate
slotting is applied.
-
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
index f7e11b09e370..1bff38f70302 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild,v 1.1 2012/06/11 18:06:40 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r1.ebuild,v 1.2 2014/02/28 19:35:04 grobian Exp $
EAPI="3"
@@ -159,7 +159,7 @@ src_configure() {
--mandir=${EPREFIX}/usr/share/gcc-data/${CTARGET}/${GCC_VERS}/man \
--infodir=${EPREFIX}/usr/share/gcc-data/${CTARGET}/${GCC_VERS}/info \
--with-gxx-include-dir=${STDCXX_INCDIR} \
- --host=${CHOST}
+ --host=${CHOST} \
--enable-version-specific-runtime-libs"
if is_crosscompile ; then
@@ -220,7 +220,7 @@ src_configure() {
# (won't hurt if already 64-bits, but is essential when coming from a
# multilib compiler -- the default)
[[ ${CTARGET} == powerpc64-* || ${CTARGET} == x86_64-* ]] && \
- export CC="gcc -m64"
+ export CC="${CC:-$(tc-getCC)} -m64"
mkdir -p "${WORKDIR}"/build
cd "${WORKDIR}"/build