summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-11-21 16:37:13 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-11-21 16:37:13 +0000
commit2295e77db6ce7cc21037142c755eead1fb532218 (patch)
tree8f2e8a3a50e9f609ab52e06fa3067d6a8c0dec35 /sys-devel
parentstable ppc, bug #435756, thanks peratu (diff)
downloadgentoo-2-2295e77db6ce7cc21037142c755eead1fb532218.tar.gz
gentoo-2-2295e77db6ce7cc21037142c755eead1fb532218.tar.bz2
gentoo-2-2295e77db6ce7cc21037142c755eead1fb532218.zip
Version bump to release version i tagged.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ucpp/ChangeLog8
-rw-r--r--sys-devel/ucpp/ucpp-1.3.3.ebuild28
-rw-r--r--sys-devel/ucpp/ucpp-1.3.ebuild4
-rw-r--r--sys-devel/ucpp/ucpp-9999.ebuild4
4 files changed, 39 insertions, 5 deletions
diff --git a/sys-devel/ucpp/ChangeLog b/sys-devel/ucpp/ChangeLog
index eec72026670b..f3ea73b20057 100644
--- a/sys-devel/ucpp/ChangeLog
+++ b/sys-devel/ucpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/ucpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ChangeLog,v 1.3 2012/09/24 13:34:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ChangeLog,v 1.4 2012/11/21 16:37:13 scarabeus Exp $
+
+*ucpp-1.3.3 (21 Nov 2012)
+
+ 21 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> +ucpp-1.3.3.ebuild,
+ ucpp-1.3.ebuild, ucpp-9999.ebuild:
+ Version bump to release version i tagged.
*ucpp-9999 (24 Sep 2012)
diff --git a/sys-devel/ucpp/ucpp-1.3.3.ebuild b/sys-devel/ucpp/ucpp-1.3.3.ebuild
new file mode 100644
index 000000000000..df585406790a
--- /dev/null
+++ b/sys-devel/ucpp/ucpp-1.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-1.3.3.ebuild,v 1.1 2012/11/21 16:37:12 scarabeus Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
+HOMEPAGE="http://code.google.com/p/ucpp/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/sys-devel/ucpp/ucpp-1.3.ebuild b/sys-devel/ucpp/ucpp-1.3.ebuild
index 788ab5e5cd56..5cdb83e0c254 100644
--- a/sys-devel/ucpp/ucpp-1.3.ebuild
+++ b/sys-devel/ucpp/ucpp-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-1.3.ebuild,v 1.2 2011/08/02 14:19:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-1.3.ebuild,v 1.3 2012/11/21 16:37:12 scarabeus Exp $
EAPI="2"
diff --git a/sys-devel/ucpp/ucpp-9999.ebuild b/sys-devel/ucpp/ucpp-9999.ebuild
index bfe5cc8e4fea..bc1df5065828 100644
--- a/sys-devel/ucpp/ucpp-9999.ebuild
+++ b/sys-devel/ucpp/ucpp-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-9999.ebuild,v 1.1 2012/09/24 13:34:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ucpp/ucpp-9999.ebuild,v 1.2 2012/11/21 16:37:12 scarabeus Exp $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/scarabeusiv/ucpp.git"
inherit eutils git-2 autotools