summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 06:11:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 06:11:28 +0000
commit46a32f99983a711cac3416ef615d6f16383d530a (patch)
treece65f65c1022924ba2c3d5ae27e31fa3dde267a2 /sys-devel
parentInitial ebuild by me. (diff)
downloadgentoo-2-46a32f99983a711cac3416ef615d6f16383d530a.tar.gz
gentoo-2-46a32f99983a711cac3416ef615d6f16383d530a.tar.bz2
gentoo-2-46a32f99983a711cac3416ef615d6f16383d530a.zip
ok, screw you echangelog
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/gcc-3.4.0.ebuild19
2 files changed, 14 insertions, 10 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index f31e8ca4ceca..251e18eab67a 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.220 2004/04/27 03:24:35 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.221 2004/04/27 06:11:28 vapier Exp $
+
+ 27 Apr 2004; Mike Frysinger <vapier@gentoo.org> gcc-3.4.0.ebuild:
+ cleanup flag stuff and remove CHOST setting with hppa gcc-3.4.0.ebuild
26 Apr 2004; Tom Gall <tgall@gentoo.org> gcc-3.4.0.ebuild:
fix bug 49111, appears to work quite well on ppc64
diff --git a/sys-devel/gcc/gcc-3.4.0.ebuild b/sys-devel/gcc/gcc-3.4.0.ebuild
index 2757e2b06f08..3e26084a9180 100644
--- a/sys-devel/gcc/gcc-3.4.0.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.7 2004/04/27 03:24:35 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0.ebuild,v 1.8 2004/04/27 06:11:28 vapier Exp $
IUSE="static nls bootstrap java build X multilib gcj hardened f77 objc uclibc"
@@ -47,10 +47,15 @@ inherit eutils flag-o-matic libtool
# problems.
#
# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
-# gcc produce unstable binaries if compiled with a different CHOST.
-[ "${ARCH}" = "hppa" ] && export CHOST="hppa-unknown-linux-gnu"
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe. This is especially true for gcc 3.3 + 3.4
+ replace-flags -O? -O2
+
+ export GCJFLAGS="${CFLAGS/-O?/-O2}"
+}
# Theoretical cross compiler support
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
@@ -390,13 +395,9 @@ src_compile() {
use x86 && myconf="${myconf} --with-cpu=pentium4 --with-arch=i586"
#use mips && myconf="${myconf} --with-arch=mips3"
- # In general gcc does not like optimization, and add -O2 where
- # it is safe. This is especially true for gcc 3.3 + 3.4
- export CFLAGS="${CFLAGS/-O?/-O2}"
+ do_filter_flags
einfo "CFLAGS=\"${CFLAGS}\""
- export CXXFLAGS="${CXXFLAGS/-O?/-O2}"
einfo "CXXFLAGS=\"${CXXFLAGS}\""
- export GCJFLAGS="${CFLAGS/-O?/-O2}"
einfo "GCJFLAGS=\"${GCJFLAGS}\""
# Build in a separate build tree