summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-09-16 04:53:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-09-16 04:53:07 +0000
commit50152ee971e9164013baa6dd834e238403ee9e60 (patch)
tree7016e61bbafe7ecdb4ad2e73d8509352ebd6b97e /sys-devel
parentRevision bump to push out patchset 1.2. Fixes kernel miscompilation (diff)
downloadgentoo-2-50152ee971e9164013baa6dd834e238403ee9e60.tar.gz
gentoo-2-50152ee971e9164013baa6dd834e238403ee9e60.tar.bz2
gentoo-2-50152ee971e9164013baa6dd834e238403ee9e60.zip
Bump 4.5.1 patchset to 1.1. Fixes bug #334269 and #331641.
Add ewarn about LTO to pkg_setup. (Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-4.5.1.ebuild18
2 files changed, 20 insertions, 4 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 39a20e4f5e02..f80a5ec45962 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.776 2010/09/16 04:18:53 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.777 2010/09/16 04:53:07 dirtyepic Exp $
+
+ 16 Sep 2010; Ryan Hill <dirtyepic@gentoo.org> gcc-4.5.1.ebuild:
+ Bump 4.5.1 patchset to 1.1. Fixes bug #334269 and #331641.
+ Add ewarn about LTO to pkg_setup.
*gcc-4.4.4-r2 (16 Sep 2010)
diff --git a/sys-devel/gcc/gcc-4.5.1.ebuild b/sys-devel/gcc/gcc-4.5.1.ebuild
index b6610fb195cd..b1a78fea089d 100644
--- a/sys-devel/gcc/gcc-4.5.1.ebuild
+++ b/sys-devel/gcc/gcc-4.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.1.ebuild,v 1.1 2010/08/07 22:45:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.1.ebuild,v 1.2 2010/09/16 04:53:07 dirtyepic Exp $
-PATCH_VER="1.0"
+PATCH_VER="1.1"
UCLIBC_VER="1.0"
ETYPE="gcc-compiler"
@@ -21,10 +21,11 @@ SSP_UCLIBC_STABLE=""
inherit toolchain
-DESCRIPTION="The GNU Compiler Collection."
+DESCRIPTION="The GNU Compiler Collection"
LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
KEYWORDS=""
+IUSE=""
RDEPEND=">=sys-libs/zlib-1.1.4
>=sys-devel/gcc-config-1.4
@@ -80,3 +81,14 @@ src_unpack() {
[[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
}
+
+pkg_setup() {
+ gcc_pkg_setup
+
+ if use lto ; then
+ ewarn
+ ewarn "LTO support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of LTO will not be fixed."
+ ewarn
+ fi
+}