summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-06-15 22:26:52 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-06-15 22:26:52 +0000
commit6d6f5b0c8b1bf5952e82ad66104e2987bac94e69 (patch)
tree15b081c918de713872bf16c96c97af1efd8768ff /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-6d6f5b0c8b1bf5952e82ad66104e2987bac94e69.tar.gz
gentoo-2-6d6f5b0c8b1bf5952e82ad66104e2987bac94e69.tar.bz2
gentoo-2-6d6f5b0c8b1bf5952e82ad66104e2987bac94e69.zip
lldb fixes thanks to mgorny's review
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild20
2 files changed, 16 insertions, 9 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index bc9fd4f032ef..335848188c00 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.252 2015/06/15 12:52:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.253 2015/06/15 22:26:52 voyageur Exp $
+
+ 15 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
+ lldb fixes thanks to mgorny's review
15 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild,
metadata.xml:
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index bf78b0036e36..5f589c32a2ef 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.117 2015/06/15 12:52:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.118 2015/06/15 22:26:52 voyageur Exp $
EAPI=5
@@ -66,8 +66,8 @@ PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- test? ( || ( $(python_gen_useflags 'python*') ) )
- lldb? ( clang )"
+ lldb? ( clang )
+ test? ( || ( $(python_gen_useflags 'python*') ) )"
pkg_pretend() {
# in megs
@@ -243,12 +243,16 @@ multilib_src_configure() {
-DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"
-DHAVE_HISTEDIT_H=$(usex libedit)
-
- -DLLDB_DISABLE_LIBEDIT=$(usex libedit 0 1)
- -DLLDB_DISABLE_CURSES=$(usex libedit 0 1)
- -DLLDB_ENABLE_TERMINFO=$(usex ncurses)
)
+ if use lldb; then
+ mycmakeargs+=(
+ -DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
+ -DLLDB_DISABLE_CURSES=$(usex !ncurses)
+ -DLLDB_ENABLE_TERMINFO=$(usex ncurses)
+ )
+ fi
+
if ! multilib_is_native_abi || ! use ocaml; then
mycmakeargs+=(
-DOCAMLFIND=NO
@@ -284,7 +288,7 @@ multilib_src_configure() {
if use lldb; then
mycmakeargs+=(
- -DLLDB_DISABLE_PYTHON=$(usex python 0 1)
+ -DLLDB_DISABLE_PYTHON=$(usex !python)
)
fi