summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-27 02:45:48 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-27 02:45:48 +0000
commitc3ba18ef34402ef97a5f5ad11111d558f032239d (patch)
tree0fbe47c832910985ac060e2b54f6a713d82a402e /sys-devel
parentStable on x86; bug #116526 (diff)
downloadgentoo-2-c3ba18ef34402ef97a5f5ad11111d558f032239d.tar.gz
gentoo-2-c3ba18ef34402ef97a5f5ad11111d558f032239d.tar.bz2
gentoo-2-c3ba18ef34402ef97a5f5ad11111d558f032239d.zip
Use get_libdir #114633 by Patrick McLean.
(Portage version: 2.1_pre2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog6
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.1216
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild11
3 files changed, 22 insertions, 11 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 4d4618d60437..113279256ca5 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.111 2005/11/19 05:23:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.112 2005/12/27 02:45:48 vapier Exp $
+
+ 27 Dec 2005; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.12,
+ gcc-config-1.3.12-r4.ebuild:
+ Use get_libdir #114633 by Patrick McLean.
*gcc-config-1.3.12-r4 (19 Nov 2005)
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index 2b08e80c2feb..c0de03df30c2 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.11 2005/12/21 01:53:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.12 2005/12/27 02:45:48 vapier Exp $
trap ":" INT QUIT TSTP
@@ -223,6 +223,12 @@ switch_profile() {
# Fix environment
source /etc/profile
umask 022
+ # Find the bin wrapper
+ local wrapper
+ for wrapper in GENTOO_LIBDIR lib lib64 lib32 lib ; do
+ wrapper="${ROOT}usr/${wrapper}/misc/gcc-config"
+ [[ -e ${wrapper} ]] && break
+ done
# Update the wrappers for this profile
local native="gcc cpp cc c++ g++ f77 g77 gcj"
@@ -242,16 +248,14 @@ switch_profile() {
[[ ${x} == "cc" ]] && ref=${ROOT}/${GCC_BIN_PATH}/gcc
[[ ${x} == "f77" ]] && ref=${ROOT}/${GCC_BIN_PATH}/g77
if [[ -x ${ref} ]] ; then
- ${CP} -f "${ROOT}/usr/lib/misc/gcc-config" \
- "${ROOT}/usr/bin/${x}"
+ ${CP} -f "${wrapper}" "${ROOT}/usr/bin/${x}"
${TOUCH} -r "${ref}" "${ROOT}/usr/bin/${x}"
# Install 32bit and 64bit wrappers if need be
# This should probably get folded back into the wrapper ...
if [[ ${x:${#x}-3} == "gcc" ]] || [[ ${x:${#x}-3} == "g++" ]] ; then
for bits in ${GCCBITS} ; do
- ${CP} -f "${ROOT}/usr/lib/misc/gcc-config" \
- "${ROOT}/usr/bin/${x}${bits}"
+ ${CP} -f "${wrapper}" "${ROOT}/usr/bin/${x}${bits}"
done
fi
fi
@@ -259,7 +263,7 @@ switch_profile() {
# Only install cpp if switching to a native one
if ! is_cross_compiler && [[ ${CTARGET} != *-solaris* ]] ; then
${RM} -f "${ROOT}/lib/cpp"
- ${CP} -f "${ROOT}/usr/lib/misc/gcc-config" "${ROOT}/lib/cpp"
+ ${CP} -f "${wrapper}" "${ROOT}/lib/cpp"
fi
# We need to make sure that libgcc_s.so / libunwind.so make it into /lib.
diff --git a/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild
index d66abe808ef0..4e07d66b7bb9 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild,v 1.1 2005/11/19 05:23:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild,v 1.2 2005/12/27 02:45:48 vapier Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs multilib
# Version of .c wrapper to use
W_VER="1.4.7"
@@ -27,9 +27,12 @@ src_compile() {
src_install() {
newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
- dosed "s:PORTAGE-VERSION:${PVR}:" /usr/bin/${PN}
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
- exeinto /usr/lib/misc
+ exeinto /usr/$(get_libdir)/misc
newexe wrapper gcc-config || die "install wrapper"
}