summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-07-13 11:52:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-07-13 11:52:09 +0000
commitd018f74931bc388245f10107f7394897aacb17a5 (patch)
tree20e33ab603145c0eb7fa21d6ec2748ca566e4bdf /sys-devel
parentremoval (bug #321685) (diff)
downloadgentoo-2-d018f74931bc388245f10107f7394897aacb17a5.tar.gz
gentoo-2-d018f74931bc388245f10107f7394897aacb17a5.tar.bz2
gentoo-2-d018f74931bc388245f10107f7394897aacb17a5.zip
Initial commit. Taking ownership. Bug #258396
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/ChangeLog8
-rw-r--r--sys-devel/ct-ng/ct-ng-1.7.1.ebuild31
-rw-r--r--sys-devel/ct-ng/files/fix-man-path.patch13
-rw-r--r--sys-devel/ct-ng/metadata.xml18
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
new file mode 100644
index 000000000000..6cb2e0f75804
--- /dev/null
+++ b/sys-devel/ct-ng/ChangeLog
@@ -0,0 +1,8 @@
+
+
+*ct-ng-1.7.1 (13 Jul 2010)
+
+ 13 Jul 2010; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.7.1.ebuild,
+ +files/fix-man-path.patch, +metadata.xml:
+ Initial commit. Taking ownership. Bug #258396
+
diff --git a/sys-devel/ct-ng/ct-ng-1.7.1.ebuild b/sys-devel/ct-ng/ct-ng-1.7.1.ebuild
new file mode 100644
index 000000000000..a7fae237aa8d
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.7.1.ebuild,v 1.1 2010/07/13 11:52:08 blueness Exp $
+
+EAPI="2"
+
+inherit eutils bash-completion
+
+DESCRIPTION="A tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-vcs/cvs"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix-man-path.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcompletion ct-ng.comp
+ dodoc README TODO docs/known-issues.txt
+}
diff --git a/sys-devel/ct-ng/files/fix-man-path.patch b/sys-devel/ct-ng/files/fix-man-path.patch
new file mode 100644
index 000000000000..2e83565d7acd
--- /dev/null
+++ b/sys-devel/ct-ng/files/fix-man-path.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2010-06-06 12:54:45.000000000 -0400
++++ configure 2010-06-06 13:28:06.000000000 -0400
+@@ -410,6 +410,10 @@
+ [ -z "${DOCDIR_set}" ] && DOCDIR="${PREFIX}/share/doc"
+ [ -z "${MANDIR_set}" ] && MANDIR="${PREFIX}/share/man/man1"
+
++# Append man1 if a autobuild style --mandir=/usr/share/man path was given
++MANDIR=${MANDIR%/}
++MANDIR=${MANDIR/\/share\/man//share/man/man1}
++
+ # Install support files in our own sub-dir, so as not to mangle (system)
+ # files and dirs, but only if not --local
+ if [ -z "${LOCAL_set}" ]; then
diff --git a/sys-devel/ct-ng/metadata.xml b/sys-devel/ct-ng/metadata.xml
new file mode 100644
index 000000000000..9e91abd4019b
--- /dev/null
+++ b/sys-devel/ct-ng/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription lang="en">
+ crosstool-NG is a utility for building cross-compiling toolchains.
+ It will only build the toolchain. It is up to use how you want to
+ use it after that.
+
+ It is an alternative to sys-devel/crossdev.
+
+ For more information, see http://ymorin.is-a-geek.org/projects/crosstool
+ </longdescription>
+</pkgmetadata>