summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-20 22:20:49 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-20 22:20:49 +0000
commite70a49d05e5ef7ae00fddc2628b9592548a74d4e (patch)
treefff7a56634c15dbf85aa8941d886dff663f03e37 /sys-devel
parentVersion bump. Updated SRC_URI and HOMEPAGE. (diff)
downloadgentoo-2-e70a49d05e5ef7ae00fddc2628b9592548a74d4e.tar.gz
gentoo-2-e70a49d05e5ef7ae00fddc2628b9592548a74d4e.tar.bz2
gentoo-2-e70a49d05e5ef7ae00fddc2628b9592548a74d4e.zip
Bump weekly 4.2 snapshot
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200605203
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060520.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 68d3277f7d0f..23f785fb5e81 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.538 2006/05/18 04:04:47 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.539 2006/05/20 22:20:49 halcy0n Exp $
+
+*gcc-4.2.0_alpha20060520 (20 May 2006)
+
+ 20 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ -gcc-4.2.0_alpha20060513.ebuild, +gcc-4.2.0_alpha20060520.ebuild:
+ Bump weekly 4.2 snapshot
*gcc-4.1.1_pre20060517 (18 May 2006)
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060520 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060520
new file mode 100644
index 000000000000..9d4ff9677de1
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060520
@@ -0,0 +1,3 @@
+MD5 31875675f6f722009db6994fa3ebb1fa gcc-4.2-20060520.tar.bz2 38944587
+RMD160 92e08b1976faf28e08adce62a7615df9cc4b5e8c gcc-4.2-20060520.tar.bz2 38944587
+SHA256 8c73cd3d243637fc03b2ebe4d57fe2007e07493cb150cb406b52da0660dedae3 gcc-4.2-20060520.tar.bz2 38944587
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060520.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060520.ebuild
new file mode 100644
index 000000000000..5d3bcb8a0fd6
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060520.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060520.ebuild,v 1.1 2006/05/20 22:20:49 halcy0n Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ dev-libs/gmp
+ dev-libs/mpfr
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? (
+ hppa? ( >=sys-libs/glibc-2.3.4 ) !hppa? ( >=sys-libs/glibc-2.3.6 )
+ )"
+fi
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+ x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}