summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-27 23:05:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-27 23:05:05 +0000
commite615a80426cd9052338fa449965c1476a929091c (patch)
treebd90be1091fc355b6644333c1a05d01e6ff2651b /sys-freebsd/freebsd-lib
parentDrop all keywords but ~amd64 to avoid breaking the deptree with emul-linux st... (diff)
downloadgentoo-2-e615a80426cd9052338fa449965c1476a929091c.tar.gz
gentoo-2-e615a80426cd9052338fa449965c1476a929091c.tar.bz2
gentoo-2-e615a80426cd9052338fa449965c1476a929091c.zip
bootstrap the libc when building a cross-compiler so that libm can be linked to it and fixes a build failure from a fresh build
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-lib')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild13
2 files changed, 14 insertions, 5 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 7908eb6d39ae..a35d93008c8e 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.186 2013/06/27 20:38:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.187 2013/06/27 23:05:05 aballier Exp $
+
+ 27 Jun 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.1-r9.ebuild:
+ bootstrap the libc when building a cross-compiler so that libm can be linked
+ to it and fixes a build failure from a fresh build
*freebsd-lib-9.1-r9 (27 Jun 2013)
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild
index 8f50af5fccf5..6d7ff0e4af36 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild,v 1.1 2013/06/27 20:38:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1-r9.ebuild,v 1.2 2013/06/27 23:05:05 aballier Exp $
EAPI=5
@@ -236,6 +236,12 @@ bootstrap_libssp_nonshared() {
export LDADD="-lssp_nonshared"
}
+bootstrap_libc() {
+ cd "${WORKDIR}/lib/libc" || die
+ freebsd_src_compile
+ append-ldflags "-L${MAKEOBJDIRPREFIX}/${WORKDIR}/lib/libc"
+}
+
bootstrap_libgcc() {
cd "${WORKDIR}/lib/libcompiler_rt" || die
freebsd_src_compile
@@ -243,9 +249,7 @@ bootstrap_libgcc() {
ln -s libcompiler_rt.a libgcc.a || die
append-ldflags "-L${MAKEOBJDIRPREFIX}/${WORKDIR}/lib/libcompiler_rt"
- cd "${WORKDIR}/lib/libc" || die
- freebsd_src_compile
- append-ldflags "-L${MAKEOBJDIRPREFIX}/${WORKDIR}/lib/libc"
+ bootstrap_libc
cd "${WORKDIR}/gnu/lib/libgcc" || die
freebsd_src_compile
@@ -310,6 +314,7 @@ do_bootstrap() {
fi
bootstrap_csu
bootstrap_libssp_nonshared
+ is_crosscompile && bootstrap_libc
if ! is_crosscompile && ! is_native_abi ; then
# Bootstrap the compiler libs
bootstrap_libgcc