summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-02 07:21:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-02 07:21:11 +0000
commit43e92c348f86e73105ee35077cfe57566cfeb906 (patch)
tree24fd3857d24621f948fbb546faf46bab03c587b8 /sys-fs/aufs3
parentNew addition, ebuild after submission by Gustavo Sverzut Barbieri, Lucian Mur... (diff)
downloadgentoo-2-43e92c348f86e73105ee35077cfe57566cfeb906.tar.gz
gentoo-2-43e92c348f86e73105ee35077cfe57566cfeb906.tar.bz2
gentoo-2-43e92c348f86e73105ee35077cfe57566cfeb906.zip
Version BUmp
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/aufs3')
-rw-r--r--sys-fs/aufs3/ChangeLog8
-rw-r--r--sys-fs/aufs3/aufs3-3_p20120402.ebuild144
-rw-r--r--sys-fs/aufs3/files/aufs3-base-x-rcN.patch10
-rw-r--r--sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch48
4 files changed, 180 insertions, 30 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index 1bb304df2b01..986d0d5ea91c 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.8 2012/03/29 07:48:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.9 2012/04/02 07:21:11 jlec Exp $
+
+*aufs3-3_p20120402 (02 Apr 2012)
+
+ 02 Apr 2012; Justin Lecher <jlec@gentoo.org> files/aufs3-base-x-rcN.patch,
+ files/aufs3-standalone-x-rcN.patch, +aufs3-3_p20120402.ebuild:
+ Version BUmp
*aufs3-3_p20120329 (29 Mar 2012)
diff --git a/sys-fs/aufs3/aufs3-3_p20120402.ebuild b/sys-fs/aufs3/aufs3-3_p20120402.ebuild
new file mode 100644
index 000000000000..8081ebf32d2d
--- /dev/null
+++ b/sys-fs/aufs3/aufs3-3_p20120402.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20120402.ebuild,v 1.1 2012/04/02 07:21:11 jlec Exp $
+
+EAPI=4
+
+inherit linux-mod multilib toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+PATCH_MAX_VER="3"
+UTIL_MAX_VER="0"
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse pax_kernel hfs inotify kernel-patch nfs ramfs"
+
+DEPEND="dev-vcs/git"
+RDEPEND="
+ !sys-fs/aufs
+ !sys-fs/aufs2"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK="${CONFIG_CHECK} ~EXPERIMENTAL"
+ use inotify && CONFIG_CHECK="${CONFIG_CHECK} ~FSNOTIFY"
+ use nfs && CONFIG_CHECK="${CONFIG_CHECK} EXPORTFS"
+ use fuse && CONFIG_CHECK="${CONFIG_CHECK} ~FUSE_FS"
+ use hfs && CONFIG_CHECK="${CONFIG_CHECK} ~HFSPLUS_FS"
+
+ # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
+ [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
+
+ get_version
+ kernel_is lt 3 0 0 && die "kernel too old, Please use sys-fs/aufs2"
+ kernel_is gt 3 3 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ if [[ "${PATCH_BRANCH}" == "x-rcN" ]]; then
+ UTIL_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" -gt "${UTIL_MAX_VER}" ]]; then
+ UTIL_BRANCH="${UTIL_MAX_VER}"
+ else
+ UTIL_BRANCH="${KV_MINOR}"
+ fi
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null && \
+ patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-standalone-${PATCH_BRANCH}.patch >/dev/null
+ patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${FILESDIR}"/${PN}-base-${PATCH_BRANCH}.patch >/dev/null
+ epatch "${FILESDIR}"/${PN}-{base,standalone}-${PATCH_BRANCH}.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply ${FILESDIR}/${PN}-base-${PATCH_BRANCH}.patch and"
+ eerror "${FILESDIR}/${PN}-standalone-${PATCH_BRANCH}.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+ local util_branch=origin/${PN}.${UTIL_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && use amd64 && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax.patch
+
+ sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
+ sed -i "s:__user::g" include/linux/aufs_type.h || die
+
+ cd "${WORKDIR}"/${PN/3}-util
+
+ einfo "Using for utils building branch ${util_branch}"
+ git checkout -b local-gentoo ${util_branch} || die
+ sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake CC=$(tc-getCC) CONFIG_AUFS_FS=m KDIR=${KV_DIR}
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake CC=$(tc-getCC) AR=$(tc-getAR) KDIR=${KV_DIR} C_INCLUDE_PATH="${S}"/include
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /usr/share/doc/${PF}
+
+ use doc && doins -r Documentation
+
+ dodoc README
+
+ cd "${WORKDIR}"/${PN/3}-util
+ emake DESTDIR="${D}" KDIR=${KV_DIR} install
+
+ newdoc README README-utils
+}
diff --git a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
index c33659cda5c1..280d36761285 100644
--- a/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-base-x-rcN.patch
@@ -1,10 +1,10 @@
aufs3.x-rcN base patch
diff --git a/fs/namei.c b/fs/namei.c
-index e2ba628..fde8ea2 100644
+index e615ff3..b9b8b85 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1781,7 +1781,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
+@@ -1904,7 +1904,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@@ -14,10 +14,10 @@ index e2ba628..fde8ea2 100644
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
-index 1ec0493..c599f73 100644
+index 5f883de..4f786e3 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1084,8 +1084,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
+@@ -1081,8 +1081,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@@ -28,7 +28,7 @@ index 1ec0493..c599f73 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
-@@ -1112,9 +1112,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1109,9 +1109,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
diff --git a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
index a828dd1222e2..10517f5036fb 100644
--- a/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
+++ b/sys-fs/aufs3/files/aufs3-standalone-x-rcN.patch
@@ -1,10 +1,10 @@
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
-index 20002e3..6d792ad 100644
+index 70f2a0f..146a3d7 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
-@@ -443,6 +443,8 @@ void file_sb_list_del(struct file *file)
+@@ -442,6 +442,8 @@ void file_sb_list_del(struct file *file)
}
}
@@ -14,10 +14,10 @@ index 20002e3..6d792ad 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
-index d3ebdbe..6db6251 100644
+index 9f4f5fe..bb0f3ba 100644
--- a/fs/inode.c
+++ b/fs/inode.c
-@@ -66,6 +66,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
+@@ -56,6 +56,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
static __cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_hash_lock);
__cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_sb_list_lock);
@@ -26,10 +26,10 @@ index d3ebdbe..6db6251 100644
/*
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
-index fde8ea2..62f2302 100644
+index b9b8b85..0fa6752 100644
--- a/fs/namei.c
+++ b/fs/namei.c
-@@ -1785,6 +1785,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
+@@ -1908,6 +1908,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@@ -123,10 +123,10 @@ index 77becc0..f634f02 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
-index c599f73..00303ba 100644
+index 4f786e3..84e5c7b 100644
--- a/fs/splice.c
+++ b/fs/splice.c
-@@ -1108,6 +1108,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+@@ -1105,6 +1105,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@@ -134,7 +134,7 @@ index c599f73..00303ba 100644
/*
* Attempt to initiate a splice from a file to a pipe.
-@@ -1134,6 +1135,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
+@@ -1131,6 +1132,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@@ -143,16 +143,16 @@ index c599f73..00303ba 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
-index 7ce191e..19a95be 100644
+index 0cf4b53..6ba43f6 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
-@@ -965,3 +965,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+@@ -966,3 +966,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
}
return ret;
}
+EXPORT_SYMBOL(cap_file_mmap);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
-index 8b5b5d8..911850c 100644
+index c43a332..0c37289 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@@ -163,7 +163,7 @@ index 8b5b5d8..911850c 100644
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
-@@ -501,6 +502,7 @@ found:
+@@ -499,6 +500,7 @@ found:
return -EPERM;
}
@@ -172,10 +172,10 @@ index 8b5b5d8..911850c 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
-index d754249..1aa6154 100644
+index bf619ff..60b996a 100644
--- a/security/security.c
+++ b/security/security.c
-@@ -392,6 +392,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
+@@ -380,6 +380,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@@ -183,7 +183,7 @@ index d754249..1aa6154 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
-@@ -408,6 +409,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
+@@ -396,6 +397,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@@ -191,7 +191,7 @@ index d754249..1aa6154 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
-@@ -416,6 +418,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
+@@ -404,6 +406,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@@ -199,7 +199,7 @@ index d754249..1aa6154 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
-@@ -434,6 +437,7 @@ int security_path_truncate(struct path *path)
+@@ -422,6 +425,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@@ -207,7 +207,7 @@ index d754249..1aa6154 100644
int security_path_chmod(struct path *path, umode_t mode)
{
-@@ -441,6 +445,7 @@ int security_path_chmod(struct path *path, umode_t mode)
+@@ -429,6 +433,7 @@ int security_path_chmod(struct path *path, umode_t mode)
return 0;
return security_ops->path_chmod(path, mode);
}
@@ -215,7 +215,7 @@ index d754249..1aa6154 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
-@@ -448,6 +453,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
+@@ -436,6 +441,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@@ -223,7 +223,7 @@ index d754249..1aa6154 100644
int security_path_chroot(struct path *path)
{
-@@ -524,6 +530,7 @@ int security_inode_readlink(struct dentry *dentry)
+@@ -512,6 +518,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@@ -231,7 +231,7 @@ index d754249..1aa6154 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
-@@ -538,6 +545,7 @@ int security_inode_permission(struct inode *inode, int mask)
+@@ -526,6 +533,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
@@ -239,7 +239,7 @@ index d754249..1aa6154 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
-@@ -653,6 +661,7 @@ int security_file_permission(struct file *file, int mask)
+@@ -641,6 +649,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@@ -247,7 +247,7 @@ index d754249..1aa6154 100644
int security_file_alloc(struct file *file)
{
-@@ -680,6 +689,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+@@ -668,6 +677,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}