summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2008-05-29 16:59:52 +0000
committerJoe Peterson <lavajoe@gentoo.org>2008-05-29 16:59:52 +0000
commitc9525e2cb07acb829ccfc7c8f258d0ab5a2a6342 (patch)
tree063294942856fb66d7b990aa57c28b3a77e1fa2b /sys-fs/btrfs
parentpython_mod_optimize is ROOT aware. Fixed python_mod_cleanup. (diff)
downloadgentoo-2-c9525e2cb07acb829ccfc7c8f258d0ab5a2a6342.tar.gz
gentoo-2-c9525e2cb07acb829ccfc7c8f258d0ab5a2a6342.tar.bz2
gentoo-2-c9525e2cb07acb829ccfc7c8f258d0ab5a2a6342.zip
Version bump to 0.15
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/btrfs')
-rw-r--r--sys-fs/btrfs/ChangeLog7
-rw-r--r--sys-fs/btrfs/btrfs-0.15.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-fs/btrfs/ChangeLog b/sys-fs/btrfs/ChangeLog
index d0f479877c89..3c84e10acaa8 100644
--- a/sys-fs/btrfs/ChangeLog
+++ b/sys-fs/btrfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/btrfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.2 2008/05/27 18:57:43 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.3 2008/05/29 16:59:52 lavajoe Exp $
+
+*btrfs-0.15 (29 May 2008)
+
+ 29 May 2008; Joe Peterson <lavajoe@gentoo.org> +btrfs-0.15.ebuild:
+ Version bump to 0.15
27 May 2008; Joe Peterson <lavajoe@gentoo.org> btrfs-0.14.ebuild:
Changed to depend on any revision of btrfs-progs
diff --git a/sys-fs/btrfs/btrfs-0.15.ebuild b/sys-fs/btrfs/btrfs-0.15.ebuild
new file mode 100644
index 000000000000..58b9e29b4ed6
--- /dev/null
+++ b/sys-fs/btrfs/btrfs-0.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.15.ebuild,v 1.1 2008/05/29 16:59:52 lavajoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="A checksumming copy-on-write filesystem"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs"
+PDEPEND="~sys-fs/btrfs-progs-${PV}"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNELDIR=/lib/modules/${KV_FULL}/build"
+ MODULE_NAMES="btrfs(fs:${S}/"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if ! linux_chkconfig_present LIBCRC32C; then
+ eerror "You need to enable LIBCRC32C in your kernel!"
+ die "You need to enable LIBCRC32C in your kernel!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_install()
+{
+ linux-mod_src_install
+
+ dodoc INSTALL TODO
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ ewarn "WARNING: Btrfs is under heavy development and is not suitable for"
+ ewarn "any uses other than benchmarking and review."
+ ewarn "The Btrfs disk format is not yet finalized."
+ ewarn ""
+ ewarn "Note: If upgrading from 0.14, there is no disk format change,"
+ ewarn " but it might be prudent to fsck after upgrading."
+}