summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-05 21:01:33 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-05 21:01:33 +0000
commit55de352becbd64dbbdb7a8a9fa570010cb92190a (patch)
treea16aac0e4721c0ecc0915209159faa391e68df6a /sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild
parentAdd patch to fix libtool-2.2 failure, bug #237611 (diff)
downloadgentoo-2-55de352becbd64dbbdb7a8a9fa570010cb92190a.tar.gz
gentoo-2-55de352becbd64dbbdb7a8a9fa570010cb92190a.tar.bz2
gentoo-2-55de352becbd64dbbdb7a8a9fa570010cb92190a.zip
Do not bang directly on /dev/console so we dont break when running under X or something.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild b/sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild
new file mode 100644
index 000000000000..881ea4b3e2c2
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.0.6-r2.ebuild,v 1.1 2008/10/05 21:01:33 vapier Exp $
+
+inherit linux-info eutils flag-o-matic multilib
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://luks.endorphin.org/"
+SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build dynamic nls selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ >=dev-libs/popt-1.7
+ >=sys-fs/udev-124
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup-luks"
+
+dm-crypt_check() {
+ local CONFIG_CHECK="~DM_CRYPT"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+crypto_check() {
+ local CONFIG_CHECK="~CRYPTO"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+}
+
+cbc_check() {
+ local CONFIG_CHECK="~CRYPTO_CBC"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ check_extra_config
+}
+
+pkg_setup() {
+ dm-crypt_check
+ crypto_check
+ cbc_check
+
+ if use dynamic ; then
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should NOT use the dynamic USE flag"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix for bug #236481, use udevadm instead of udevsettle
+ epatch "${FILESDIR}"/${PN}-1.0.6-udevsettle.patch
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rmdir "${D}"/usr/$(get_libdir)/cryptsetup
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/1.0.6-r2-dm-crypt-start.sh dm-crypt-start.sh || die
+ newins "${FILESDIR}"/1.0.5-dm-crypt-stop.sh dm-crypt-stop.sh || die
+ newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt || die
+ newinitd "${FILESDIR}"/1.0.5-dmcrypt.rc dmcrypt || die
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "than the last version. If you are currently using /etc/conf.d/cryptfs"
+ ewarn "then you *MUST* copy your old file to:"
+ ewarn "/etc/conf.d/dmcrypt"
+ ewarn "Or your encrypted partitions will *NOT* work."
+ elog "Please see the example for configuring a LUKS mountpoint"
+ elog "in /etc/conf.d/dmcrypt"
+ elog
+ elog "If you are using baselayout-2 then please do:"
+ elog "rc-update add dmcrypt boot"
+ elog "This version introduces a command line arguement 'key_timeout'."
+ elog "If you want the search for the removable key device to timeout"
+ elog "after 10 seconds add the following to your bootloader config:"
+ elog "key_timeout=10"
+ elog "A timeout of 0 will mean it will wait indefinitely."
+}