summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-02-23 15:36:12 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-02-23 15:36:12 +0000
commit89b5cd6c8c43b2455dd1ca9c973a777dab5826f5 (patch)
tree775aa47580afb86c481751e20c7d6559be4c87c9 /sys-fs/dazuko
parentVersion bump (diff)
downloadgentoo-2-89b5cd6c8c43b2455dd1ca9c973a777dab5826f5.tar.gz
gentoo-2-89b5cd6c8c43b2455dd1ca9c973a777dab5826f5.tar.bz2
gentoo-2-89b5cd6c8c43b2455dd1ca9c973a777dab5826f5.zip
Fix bug#168051
(Portage version: 2.1.2-r10)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog6
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r3.ebuild12
-rw-r--r--sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild19
3 files changed, 20 insertions, 17 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index e4e2b95e6905..728ddc35c59d 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.20 2007/01/31 22:51:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.21 2007/02/23 15:36:12 alonbl Exp $
+
+ 23 Feb 2007; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.2-r3.ebuild,
+ dazuko-2.3.3_pre1.ebuild:
+ Fix bug#168051
31 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org> dazuko-2.3.3_pre1.ebuild:
Added kernel 2.4 support, bug#164754, thanks to f.mensik
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
index 835fbc0230d5..61e3a4082922 100644
--- a/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
+++ b/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild,v 1.2 2007/01/10 17:52:46 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r3.ebuild,v 1.3 2007/02/23 15:36:12 alonbl Exp $
inherit linux-mod toolchain-funcs flag-o-matic
DESCRIPTION="Linux kernel module and interface providing file access control"
@@ -16,13 +16,13 @@ DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
RDEPEND=${DEPEND}
S="${WORKDIR}/${MY_P}"
-# kernel settings
-CONFIG_CHECK="SECURITY_CAPABILITIES"
-MODULE_NAMES="dazuko(misc:)"
-BUILD_TARGETS="dummy_rule"
-
pkg_setup() {
[ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ MODULE_NAMES="dazuko(misc:)"
+ BUILD_TARGETS="dummy_rule"
+
}
src_unpack() {
diff --git a/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild b/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
index df3dc0e651b9..3197c9cd24b4 100644
--- a/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
+++ b/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild,v 1.2 2007/01/31 22:51:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.3_pre1.ebuild,v 1.3 2007/02/23 15:36:12 alonbl Exp $
inherit linux-mod toolchain-funcs flag-o-matic
@@ -16,17 +16,16 @@ DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
RDEPEND=${DEPEND}
S="${WORKDIR}/${MY_P}"
-# kernel settings
-if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
- BUILD_TARGETS="all"
-else
- CONFIG_CHECK="SECURITY_CAPABILITIES"
- BUILD_TARGETS="dummy_rule"
-fi
-MODULE_NAMES="dazuko(misc:)"
-
pkg_setup() {
[ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+ else
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ BUILD_TARGETS="dummy_rule"
+ fi
+ MODULE_NAMES="dazuko(misc:)"
}
src_compile() {