summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-12-05 12:51:13 +0000
committerFabian Groffen <grobian@gentoo.org>2010-12-05 12:51:13 +0000
commitf4793940422c18e1314ab441ed0b01287f652735 (patch)
treec4a17ff3990759aaa0d601fde4b175b192a49a62 /sys-fs/e2fsprogs
parentVersion Bump (diff)
downloadgentoo-2-f4793940422c18e1314ab441ed0b01287f652735.tar.gz
gentoo-2-f4793940422c18e1314ab441ed0b01287f652735.tar.bz2
gentoo-2-f4793940422c18e1314ab441ed0b01287f652735.zip
Fix Darwin Makefile patch, it was obviously blindly ported to a newer version. Re-add removed docs to patches.
(Portage version: 2.2.01.17304-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog8
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-makefile.patch37
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch8
3 files changed, 36 insertions, 17 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index b7226d5953b6..ba15ffff73c0 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.227 2010/12/04 22:29:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.228 2010/12/05 12:51:13 grobian Exp $
+
+ 05 Dec 2010; Fabian Groffen <grobian@gentoo.org>
+ files/e2fsprogs-1.41.12-darwin-makefile.patch,
+ files/e2fsprogs-1.41.12-darwin-no-mntent.patch:
+ Fix Darwin Makefile patch, it was obviously blindly ported to a newer
+ version. Re-add removed docs to patches.
04 Dec 2010; Mike Frysinger <vapier@gentoo.org> e2fsprogs-1.41.12-r1.ebuild,
+files/e2fsprogs-1.41.12-getpagesize.patch:
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-makefile.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-makefile.patch
index f3a5eaabdfd5..84440671aef0 100644
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-makefile.patch
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-makefile.patch
@@ -5,10 +5,8 @@ against the ELF Makefile.
http://sourceforge.net/tracker/index.php?func=detail&aid=2555389&group_id=2406&atid=302406
-diff --git a/lib/Makefile.darwin-lib b/lib/Makefile.darwin-lib
-index c94a5e7..6a11a66 100644
---- a/lib/Makefile.darwin-lib
-+++ b/lib/Makefile.darwin-lib
+--- lib/Makefile.darwin-lib
++++ lib/Makefile.darwin-lib
@@ -1,14 +1,15 @@
#
-# This is a Makefile stub which handles the creation of Darwin BSD shared
@@ -33,7 +31,7 @@ index c94a5e7..6a11a66 100644
all:: image
-@@ -16,36 +17,53 @@ real-subdirs:: Makefile
+@@ -16,36 +17,58 @@
$(E) " MKDIR pic"
$(Q) mkdir -p pic
@@ -45,12 +43,13 @@ index c94a5e7..6a11a66 100644
-image: $(BSD_LIB)
+image: $(ELF_LIB)
- $(BSD_LIB): $(OBJS)
+-$(BSD_LIB): $(OBJS)
- $(E) " GEN_BSD_SOLIB $(BSD_LIB)"
- $(Q) (cd pic; $(CC) -dynamiclib -compatibility_version 1.0 -current_version $(BSDLIB_VERSION) \
- -flat_namespace -undefined warning -o $(BSD_LIB) $(OBJS))
- $(Q) $(MV) pic/$(BSD_LIB) .
- $(Q) $(RM) -f ../$(BSD_LIB)
++$(ELF_LIB): $(OBJS)
+ $(E) " GEN_ELF_SOLIB $(ELF_LIB)"
+ $(Q) (cd pic; $(CC) -dynamiclib -o $(ELF_LIB) $(LDFLAGS) \
+ -Wl,-install_name,$(libdir)/$(ELF_SONAME) $(OBJS) $(ELF_OTHER_LIBS))
@@ -59,8 +58,15 @@ index c94a5e7..6a11a66 100644
$(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) \
- `echo $(my_dir) | sed -e 's;lib/;;'`/$(BSD_LIB) $(BSD_LIB))
- $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) $(BSD_LIB) $(BSDLIB_IMAGE).dylib)
+-
+-install-shlibs install:: $(BSD_LIB)
+- $(E) " INSTALL_PROGRAM $(BSDLIB_INSTALL_DIR)/$(BSD_LIB)"
+- $(Q) $(INSTALL_PROGRAM) $(BSD_LIB) \
+- $(DESTDIR)$(BSDLIB_INSTALL_DIR)/$(BSD_LIB)
+- -$(Q) $(LDCONFIG)
+ `echo $(my_dir) | sed -e 's;lib/;;'`/$(ELF_LIB) $(ELF_LIB))
-+ $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) ../$(ELF_SONAME))
++ $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) $(ELF_LIB) $(ELF_IMAGE).dylib)
++ $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) $(ELF_LIB) $(ELF_SONAME))
+
+installdirs-elf-lib::
+ $(E) " MKINSTALLDIRS $(ELF_INSTALL_DIR) $(libdir)"
@@ -68,20 +74,19 @@ index c94a5e7..6a11a66 100644
+ $(DESTDIR)$(libdir)
+
+installdirs:: installdirs-elf-lib
-
--install-shlibs install:: $(BSD_LIB)
-- $(E) " INSTALL_PROGRAM $(BSDLIB_INSTALL_DIR)/$(BSD_LIB)"
-- $(Q) $(INSTALL_PROGRAM) $(BSD_LIB) \
-- $(DESTDIR)$(BSDLIB_INSTALL_DIR)/$(BSD_LIB)
-- -$(Q) $(LDCONFIG)
++
+install-shlibs install:: $(ELF_LIB) installdirs-elf-lib
+ $(E) " INSTALL-ELF-LIB $(ELF_INSTALL_DIR)/$(ELF_LIB)"
+ $(Q) $(INSTALL_PROGRAM) $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
+ $(E) " SYMLINK $(ELF_INSTALL_DIR)/$(ELF_SONAME)"
+ $(Q) $(LN_S) -f $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
+ $(E) " SYMLINK $(libdir)/$(ELF_IMAGE).dylib"
-+ $(Q) $(LN_S) -f $(ELF_SONAME) \
-+ $(DESTDIR)$(libdir)/$(ELF_IMAGE).dylib
++ $(Q) if test "$(ELF_INSTALL_DIR)" = "$(libdir)"; then \
++ $(LN_S) -f $(ELF_SONAME) $(DESTDIR)$(libdir)/$(ELF_IMAGE).dylib ; \
++ else \
++ $(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
++ $(DESTDIR)$(libdir)/$(ELF_IMAGE).dylib; \
++ fi
install-strip: install
+ $(E) " STRIP-LIB $(ELF_INSTALL_DIR)/$(ELF_LIB)"
@@ -90,7 +95,7 @@ index c94a5e7..6a11a66 100644
install-shlibs-strip: install-shlibs
+ $(E) " STRIP-LIB $(ELF_INSTALL_DIR)/$(ELF_LIB)"
-+ @$(STRIP) --strip-unneeded --remove-section=.comment \
++ $(Q) $(STRIP) --strip-unneeded --remove-section=.comment \
+ --remove-section=.note $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
uninstall-shlibs uninstall::
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch
index ceb565d8fcd3..91ffb2c0ef94 100644
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch
@@ -1,3 +1,11 @@
+Dirk Tilger <dirk@miriup.de>:
+ For the mntent.patch: e2fsprogs is using a GNU libc specific
+ operation: setmntent and endmntent. Both operate on /etc/mtab, which
+ doesn't exist on MacOSX, thus they are simply not called on
+ Darwin.
+
+http://bugs.gentoo.org/show_bug.cgi?id=263841
+
diff --git a/misc/ismounted.c b/misc/ismounted.c
index 50b4140..84579a4 100644
--- a/misc/ismounted.c