summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-10-31 03:30:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-10-31 03:30:10 +0000
commit35cdb8bdf608738668899d706338b4e710ee61c0 (patch)
tree5c4dd1076e142dee2766bed57ad073dde8e4a0e2 /sys-fs/fuse
parentNew ebuild for Java annotations, required for the findbugs package. (diff)
downloadgentoo-2-35cdb8bdf608738668899d706338b4e710ee61c0.tar.gz
gentoo-2-35cdb8bdf608738668899d706338b4e710ee61c0.tar.bz2
gentoo-2-35cdb8bdf608738668899d706338b4e710ee61c0.zip
Version bump. Thanks to Rafał Mużyło <galtgendo@o2.pl> for the ebuild work.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/fuse-2.8.1.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 7282ed53eb34..ab3f1ff4e708 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.124 2009/10/28 04:16:34 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.125 2009/10/31 03:30:10 robbat2 Exp $
+
+*fuse-2.8.1 (31 Oct 2009)
+
+ 31 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> +fuse-2.8.1.ebuild:
+ Version bump. Thanks to Rafał Mużyło <galtgendo@o2.pl> for the ebuild
+ work.
28 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> fuse-2.7.4-r1.ebuild:
USE=modules support for sys-fs/fuse.
diff --git a/sys-fs/fuse/fuse-2.8.1.ebuild b/sys-fs/fuse/fuse-2.8.1.ebuild
new file mode 100644
index 000000000000..877f3798109c
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.8.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.1.ebuild,v 1.1 2009/10/31 03:30:10 robbat2 Exp $
+
+EAPI=2
+inherit eutils libtool linux-info
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-example \
+ || die "econf failed for fuse userland"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ rm -rf "${D}/dev"
+
+ dodir /etc
+ cat >"${D}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}