summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-22 09:32:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-22 09:32:43 +0000
commit6355aa12b212b77f61408cc4821237baff3de6be (patch)
tree6982b37dcadbee5e8d7abfa830f04e21854abdf3 /sys-fs/fuse
parentprefix linux-only DEPENDs with kernel_linux? and only run needed functions in... (diff)
downloadgentoo-2-6355aa12b212b77f61408cc4821237baff3de6be.tar.gz
gentoo-2-6355aa12b212b77f61408cc4821237baff3de6be.tar.bz2
gentoo-2-6355aa12b212b77f61408cc4821237baff3de6be.zip
Cleanup postinst and add basic BSD functionality though no keyword yet, bug 133548, thanks to Robert Sebastian Gerus <arachnist@gmail.com>
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/fuse-2.6.0_pre2.ebuild30
2 files changed, 23 insertions, 13 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 1050a490b8f1..4e68e99f980d 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.51 2006/05/15 11:01:38 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.52 2006/05/22 09:32:43 genstef Exp $
+
+ 22 May 2006; Stefan Schweizer <genstef@gentoo.org> fuse-2.6.0_pre2.ebuild:
+ Cleanup postinst and add basic BSD functionality though no keyword yet, bug
+ 133548, thanks to Robert Sebastian Gerus <arachnist@gmail.com>
15 May 2006; Stefan Schweizer <genstef@gentoo.org>
-files/fuse-2.6.16.patch, -files/fuse-fix-memleak.patch,
diff --git a/sys-fs/fuse/fuse-2.6.0_pre2.ebuild b/sys-fs/fuse/fuse-2.6.0_pre2.ebuild
index 7aa977b04f2d..f9bfe29379b8 100644
--- a/sys-fs/fuse/fuse-2.6.0_pre2.ebuild
+++ b/sys-fs/fuse/fuse-2.6.0_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_pre2.ebuild,v 1.7 2006/05/15 11:01:38 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_pre2.ebuild,v 1.8 2006/05/22 09:32:43 genstef Exp $
inherit linux-mod eutils
@@ -12,6 +12,7 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ~ia64 ppc ~ppc64 sparc x86"
IUSE=""
S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
MODULE_NAMES="fuse(fs:${S}/kernel)"
CONFIG_CHECK="@FUSE_FS:fuse"
@@ -22,6 +23,10 @@ ECONF_PARAMS="--with-kernel=${KV_OUT_DIR}"
FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
We will continue, but we wont build the module this time."
+pkg_setup() {
+ use kernel_linux && linux-mod_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,9 +39,11 @@ src_compile() {
die "econf failed for fuse userland"
emake || die "emake failed"
- sed -i 's/.*depmod.*//g' ${S}/kernel/Makefile.in
- convert_to_m ${S}/kernel/Makefile.in
- linux-mod_src_compile
+ if use kernel_linux; then
+ sed -i -e 's/.*depmod.*//g' ${S}/kernel/Makefile.in
+ convert_to_m ${S}/kernel/Makefile.in
+ linux-mod_src_compile
+ fi
}
src_install() {
@@ -47,15 +54,14 @@ src_install() {
docinto example
dodoc example/*
- linux-mod_src_install
+ if use kernel_linux; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
}
pkg_postinst() {
- check_extra_config
- strip_modulenames
- if [ -n "${MODULE_NAMES}" ]; then
- update_depmod;
- update_modules;
- update_moduledb;
- fi
+ use kernel_linux && linux-mod_pkg_postinst
}