summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-04-29 07:07:12 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-04-29 07:07:12 +0000
commit8802909c7e2cb76fa023fda07271aba7fe7519da (patch)
tree434757ee4183859c63e8222b8257dce3b807f61a /sys-fs/fuse
parentversion bump (diff)
downloadgentoo-2-8802909c7e2cb76fa023fda07271aba7fe7519da.tar.gz
gentoo-2-8802909c7e2cb76fa023fda07271aba7fe7519da.tar.bz2
gentoo-2-8802909c7e2cb76fa023fda07271aba7fe7519da.zip
version bump, bug 216572
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog9
-rw-r--r--sys-fs/fuse/files/fuse-2.6.22.patch49
-rw-r--r--sys-fs/fuse/fuse-2.6.4-r1.ebuild87
-rw-r--r--sys-fs/fuse/fuse-2.7.1.ebuild85
-rw-r--r--sys-fs/fuse/fuse-2.7.3.ebuild (renamed from sys-fs/fuse/fuse-2.7.2.ebuild)2
5 files changed, 9 insertions, 223 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 9ccd34eec726..948da167e579 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.112 2008/03/23 21:46:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.113 2008/04/29 07:07:12 genstef Exp $
+
+*fuse-2.7.3 (29 Apr 2008)
+
+ 29 Apr 2008; Stefan Schweizer <genstef@gentoo.org>
+ -files/fuse-2.6.22.patch, -fuse-2.6.4-r1.ebuild, -fuse-2.7.1.ebuild,
+ -fuse-2.7.2.ebuild, +fuse-2.7.3.ebuild:
+ version bump, bug 216572
23 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> fuse-2.6.4-r1.ebuild,
fuse-2.7.0.ebuild, fuse-2.7.1.ebuild, fuse-2.7.2.ebuild:
diff --git a/sys-fs/fuse/files/fuse-2.6.22.patch b/sys-fs/fuse/files/fuse-2.6.22.patch
deleted file mode 100644
index c1af56511e3b..000000000000
--- a/sys-fs/fuse/files/fuse-2.6.22.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- fuse-2.6.4-r1/work/fuse-2.6.4/kernel/file.c 2007-05-19 19:54:45.000000000 +0930
-+++ fuse-2.6.4-r1/work/fuse-2.6.4/kernel/file.c 2007-05-19 19:58:40.000000000 +0930
-@@ -781,7 +781,8 @@
-
- if (cmd == F_GETLK) {
- if (fc->no_lock) {
--#ifdef KERNEL_2_6_17_PLUS
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 17) && \
-+ LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 22)
- if (!posix_test_lock(file, fl, fl))
- fl->fl_type = F_UNLCK;
- #else
---- fuse-2.6.4-r1/work/fuse-2.6.4/kernel/inode.c 2007-05-20 09:13:34.000000000 +0930
-+++ fuse-2.6.4-r1/work/fuse-2.6.4/kernel/inode.c 2007-05-20 09:18:33.000000000 +0930
-@@ -809,9 +809,13 @@
- {
- struct inode * inode = foo;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
-+ inode_init_once(inode);
-+#else
- if ((flags & (SLAB_CTOR_VERIFY|SLAB_CTOR_CONSTRUCTOR)) ==
- SLAB_CTOR_CONSTRUCTOR)
- inode_init_once(inode);
-+#endif
- }
-
- static int __init fuse_fs_init(void)
-@@ -860,12 +864,20 @@
- if (err)
- return err;
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
-+ kobj_set_kset_s(&fuse_subsys, fs_subsys);
-+#else
- kset_set_kset_s(&fuse_subsys, fs_subsys);
-+#endif
- err = subsystem_register(&fuse_subsys);
- if (err)
- goto out_err;
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
-+ kobj_set_kset_s(&connections_subsys, fuse_subsys);
-+#else
- kset_set_kset_s(&connections_subsys, fuse_subsys);
-+#endif
- err = subsystem_register(&connections_subsys);
- if (err)
- goto out_fuse_unregister;
diff --git a/sys-fs/fuse/fuse-2.6.4-r1.ebuild b/sys-fs/fuse/fuse-2.6.4-r1.ebuild
deleted file mode 100644
index 914dbbe920aa..000000000000
--- a/sys-fs/fuse/fuse-2.6.4-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.4-r1.ebuild,v 1.12 2008/03/23 21:46:08 robbat2 Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is ge 2 6 23; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- epatch "${FILESDIR}"/fuse-2.6.22.patch
- sed -i -e "s:die {:die() {:" util/mount.fuse
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.7.1.ebuild b/sys-fs/fuse/fuse-2.7.1.ebuild
deleted file mode 100644
index ac1c29e0ab96..000000000000
--- a/sys-fs/fuse/fuse-2.7.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.1.ebuild,v 1.3 2008/03/23 21:46:08 robbat2 Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-pkg_setup() {
- if use kernel_linux ; then
- if kernel_is ge 2 6 24; then
- CONFIG_CHECK="FUSE_FS"
- FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
- else
- MODULE_NAMES="fuse(fs:${S}/kernel)"
- CONFIG_CHECK="@FUSE_FS:fuse"
- FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
- We will continue, but we wont build the module this time."
-
- fi
- linux-mod_pkg_setup
- kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
- older version from viewcvs"
-
- BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR} \
- fusemoduledir=\"${ROOT}\"/lib/modules/${KV_FULL/\ }/fs"
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README \
- README.NFS NEWS doc/how-fuse-works \
- doc/kernel.txt FAQ
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- newinitd ${FILESDIR}/fuse.init fuse
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- newinitd ${FILESDIR}/fuse-fbsd.init fuse
- fi
-
- rm -rf "${D}/dev"
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.7.2.ebuild b/sys-fs/fuse/fuse-2.7.3.ebuild
index ba36b9e4612c..1f1ef46d5cc1 100644
--- a/sys-fs/fuse/fuse-2.7.2.ebuild
+++ b/sys-fs/fuse/fuse-2.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.2.ebuild,v 1.3 2008/03/23 21:46:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.3.ebuild,v 1.1 2008/04/29 07:07:12 genstef Exp $
inherit linux-mod eutils libtool