summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:34:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:34:30 +0000
commit94ba8216b3095e78bac5df73c4ee499666299c0a (patch)
treed68d70abb3ee11e8c285d84868e040d48d2953c6 /sys-fs/lvm2/lvm2-2.02.45.ebuild
parentStable on sparc, bug #260063 (diff)
downloadgentoo-2-94ba8216b3095e78bac5df73c4ee499666299c0a.tar.gz
gentoo-2-94ba8216b3095e78bac5df73c4ee499666299c0a.tar.bz2
gentoo-2-94ba8216b3095e78bac5df73c4ee499666299c0a.zip
Bug #265593: Provide better workaround for the symlink parallel make bug. Real fix needs upstream to change chunks of the build setup.
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/lvm2/lvm2-2.02.45.ebuild')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.45.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.45.ebuild b/sys-fs/lvm2/lvm2-2.02.45.ebuild
index 2696ea0cbed8..f7ae5067840f 100644
--- a/sys-fs/lvm2/lvm2-2.02.45.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.45.ebuild,v 1.4 2009/04/12 20:23:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.45.ebuild,v 1.5 2009/04/12 20:34:30 robbat2 Exp $
inherit eutils multilib toolchain-funcs
@@ -94,8 +94,10 @@ src_compile() {
--libdir=/usr/$(get_libdir) \
${myconf} \
CLDFLAGS="${LDFLAGS}" || die
-
- MAKEOPTS="${MAKEOPTS} -j1"
+
+ pushd include
+ emake || die "Failed to prepare symlinks"
+ popd
emake || die "compile problem"
}