summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-13 13:51:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-13 13:51:25 +0000
commit70026c4fe5d2643f9822a5e08f1387c289543536 (patch)
tree0d30d8147c19cfeff10b68282267e52a7510cc9a /sys-fs/quotatool
parentdev-lang/mosml Fix lack of respect for LDFLAGS and jobserver. (diff)
downloadgentoo-2-70026c4fe5d2643f9822a5e08f1387c289543536.tar.gz
gentoo-2-70026c4fe5d2643f9822a5e08f1387c289543536.tar.bz2
gentoo-2-70026c4fe5d2643f9822a5e08f1387c289543536.zip
Version bump; remove obsolete non-stable versions; add patch to fix ldflags handling (bug #335955); fix symlinked autotools.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/quotatool')
-rw-r--r--sys-fs/quotatool/ChangeLog12
-rw-r--r--sys-fs/quotatool/files/quotatool-1.4.11-ldflags.patch27
-rw-r--r--sys-fs/quotatool/quotatool-1.4.11.ebuild (renamed from sys-fs/quotatool/quotatool-1.4.7.ebuild)21
-rw-r--r--sys-fs/quotatool/quotatool-1.4.8.ebuild20
-rw-r--r--sys-fs/quotatool/quotatool-1.4.9.ebuild20
5 files changed, 54 insertions, 46 deletions
diff --git a/sys-fs/quotatool/ChangeLog b/sys-fs/quotatool/ChangeLog
index 7844fd7b8cd8..c9bda171bfe1 100644
--- a/sys-fs/quotatool/ChangeLog
+++ b/sys-fs/quotatool/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/quotatool
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/ChangeLog,v 1.8 2007/06/04 18:04:01 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/ChangeLog,v 1.9 2011/01/13 13:51:25 flameeyes Exp $
+
+*quotatool-1.4.11 (13 Jan 2011)
+
+ 13 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -quotatool-1.4.7.ebuild, -quotatool-1.4.8.ebuild, -quotatool-1.4.9.ebuild,
+ +quotatool-1.4.11.ebuild, +files/quotatool-1.4.11-ldflags.patch:
+ Version bump; remove obsolete non-stable versions; add patch to fix ldflags
+ handling (bug #335955); fix symlinked autotools.
*quotatool-1.4.9 (04 Jun 2007)
diff --git a/sys-fs/quotatool/files/quotatool-1.4.11-ldflags.patch b/sys-fs/quotatool/files/quotatool-1.4.11-ldflags.patch
new file mode 100644
index 000000000000..4f028227db7b
--- /dev/null
+++ b/sys-fs/quotatool/files/quotatool-1.4.11-ldflags.patch
@@ -0,0 +1,27 @@
+Index: quotatool-1.4.11/local.mk.in
+===================================================================
+--- quotatool-1.4.11.orig/local.mk.in
++++ quotatool-1.4.11/local.mk.in
+@@ -17,7 +17,8 @@ SHELL := /bin/sh
+
+ CC := @CC@
+ CFLAGS := @CFLAGS@
+-CPPFLAGS = $(inc) @DEFS@
++LDFLAGS := @LDFLAGS@
++CPPFLAGS = @CPPFLAGS@ $(inc) @DEFS@
+
+
+ INSTALL := @INSTALL@
+Index: quotatool-1.4.11/Makefile
+===================================================================
+--- quotatool-1.4.11.orig/Makefile
++++ quotatool-1.4.11/Makefile
+@@ -58,7 +58,7 @@ subdirs := src
+ # compile the program (and the objects)
+ all: $(prog)
+ $(prog): $(objs)
+- $(CC) -o $(prog) $(objs) $(libs) $(CFLAGS)
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(prog) $(objs) $(libs)
+
+
+
diff --git a/sys-fs/quotatool/quotatool-1.4.7.ebuild b/sys-fs/quotatool/quotatool-1.4.11.ebuild
index 10a2575903f2..526d899a0591 100644
--- a/sys-fs/quotatool/quotatool-1.4.7.ebuild
+++ b/sys-fs/quotatool/quotatool-1.4.11.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/quotatool-1.4.7.ebuild,v 1.1 2005/07/17 13:29:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/quotatool-1.4.11.ebuild,v 1.1 2011/01/13 13:51:25 flameeyes Exp $
+
+EAPI=2
+
+inherit autotools eutils
DESCRIPTION="command-line utility for filesystem quotas"
HOMEPAGE="http://quotatool.ekenberg.se/"
@@ -12,9 +16,18 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RDEPEND="sys-fs/quota"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ # rebuild autotools since it uses symlinked copies of support files
+ # that we can't rely on.
+ eautoreconf
+}
src_install () {
dobin quotatool || die
- doman man/quotatool.8
- dodoc AUTHORS ChangeLog README TODO
+ doman man/quotatool.8 || die
+ dodoc AUTHORS ChangeLog README TODO || die
}
diff --git a/sys-fs/quotatool/quotatool-1.4.8.ebuild b/sys-fs/quotatool/quotatool-1.4.8.ebuild
deleted file mode 100644
index 3b9c821338b8..000000000000
--- a/sys-fs/quotatool/quotatool-1.4.8.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/quotatool-1.4.8.ebuild,v 1.1 2006/01/26 01:09:48 vapier Exp $
-
-DESCRIPTION="command-line utility for filesystem quotas"
-HOMEPAGE="http://quotatool.ekenberg.se/"
-SRC_URI="http://quotatool.ekenberg.se/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="sys-fs/quota"
-
-src_install () {
- dobin quotatool || die
- doman man/quotatool.8
- dodoc AUTHORS ChangeLog README TODO
-}
diff --git a/sys-fs/quotatool/quotatool-1.4.9.ebuild b/sys-fs/quotatool/quotatool-1.4.9.ebuild
deleted file mode 100644
index 337f1110ed4a..000000000000
--- a/sys-fs/quotatool/quotatool-1.4.9.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quotatool/quotatool-1.4.9.ebuild,v 1.1 2007/06/04 18:04:01 robbat2 Exp $
-
-DESCRIPTION="command-line utility for filesystem quotas"
-HOMEPAGE="http://quotatool.ekenberg.se/"
-SRC_URI="http://quotatool.ekenberg.se/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="sys-fs/quota"
-
-src_install () {
- dobin quotatool || die
- doman man/quotatool.8
- dodoc AUTHORS ChangeLog README TODO
-}