summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-08-02 09:20:20 +0000
committerRoy Marples <uberlord@gentoo.org>2007-08-02 09:20:20 +0000
commite57f771a089fe39f65a44e310677f924ff684157 (patch)
treeefbcc8b347c1a4dd07165ecae765eab12ff759a6 /sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild
parentFix ESVN_REPO_URI wrt bug #187462. Thanks to Michael Mysinger. (diff)
downloadgentoo-2-e57f771a089fe39f65a44e310677f924ff684157.tar.gz
gentoo-2-e57f771a089fe39f65a44e310677f924ff684157.tar.bz2
gentoo-2-e57f771a089fe39f65a44e310677f924ff684157.zip
Add a patch to allow fsck -f -n to work, #116016
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild')
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild
new file mode 100644
index 000000000000..f0ab652a657b
--- /dev/null
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.20-r1.ebuild,v 1.1 2007/08/02 09:20:20 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.namesys.com/"
+SRC_URI="http://www.namesys.com/pub/reiserfsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# big endian has broken code (doesnt compile) #154294
+KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 -mips -ppc -ppc64 -sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fsck-n.patch
+}
+
+src_compile() {
+ econf --prefix=/ || die "Failed to configure"
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc ChangeLog INSTALL README
+}