summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-31 10:22:47 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-31 10:22:47 +0000
commitb75a081634f8b68dc4ff3271046bb10dbda05609 (patch)
treeab1633d3e46860c909a806ee49d0aaaa156a92b9 /sys-fs/safecopy
parentKeep it just on x11 team. No need for double mails for me. (diff)
downloadgentoo-2-b75a081634f8b68dc4ff3271046bb10dbda05609.tar.gz
gentoo-2-b75a081634f8b68dc4ff3271046bb10dbda05609.tar.bz2
gentoo-2-b75a081634f8b68dc4ff3271046bb10dbda05609.zip
EAPI=4. Stabilise on amd64 and x86.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/safecopy')
-rw-r--r--sys-fs/safecopy/ChangeLog5
-rw-r--r--sys-fs/safecopy/safecopy-1.6.ebuild26
2 files changed, 16 insertions, 15 deletions
diff --git a/sys-fs/safecopy/ChangeLog b/sys-fs/safecopy/ChangeLog
index 64c24dd8cbde..d1747d55d5de 100644
--- a/sys-fs/safecopy/ChangeLog
+++ b/sys-fs/safecopy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/safecopy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/ChangeLog,v 1.6 2011/01/05 09:57:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/ChangeLog,v 1.7 2011/05/31 10:22:47 scarabeus Exp $
+
+ 31 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> safecopy-1.6.ebuild:
+ EAPI=4. Stabilise on amd64 and x86.
*safecopy-1.6 (05 Jan 2011)
diff --git a/sys-fs/safecopy/safecopy-1.6.ebuild b/sys-fs/safecopy/safecopy-1.6.ebuild
index 6759a05c4e90..d9414f2d96fb 100644
--- a/sys-fs/safecopy/safecopy-1.6.ebuild
+++ b/sys-fs/safecopy/safecopy-1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/safecopy-1.6.ebuild,v 1.1 2011/01/05 09:57:51 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/safecopy/safecopy-1.6.ebuild,v 1.2 2011/05/31 10:22:47 scarabeus Exp $
-EAPI=3
+EAPI=4
inherit base
@@ -12,39 +12,37 @@ SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="test"
RDEPEND=""
DEPEND=""
+DOCS=( README )
+
src_prepare() {
+ base_src_prepare
sed -e 's:bin/sh:bin/bash:' \
- -i "${S}"/test/test.sh || die "sed failed"
+ -i "${S}"/test/test.sh || die
}
src_configure() {
- base_src_configure
+ default_src_configure
if use test; then
cd "${S}"/simulator
- econf
+ default_src_configure
fi
}
src_compile() {
- base_src_compile
+ default_src_compile
if use test; then
cd "${S}"/simulator
- emake || die "Simulator compilation failed -- needed for testing"
+ default_src_compile
fi
}
-src_install() {
- base_src_install
- dodoc README || die "copying documentation failed"
-}
-
src_test() {
cd "${S}"/test
- ./test.sh || die "./tesh.sh failed"
+ ./test.sh || die
}