summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Mylchreest <johnm@gentoo.org>2006-03-20 22:01:10 +0000
committerJohn Mylchreest <johnm@gentoo.org>2006-03-20 22:01:10 +0000
commitc8196bfce18765e9ab7379789c9262470dd9aea1 (patch)
treeae4f0cdabe1b6ced9135f342934a96461bc2284e /sys-fs/static-dev/static-dev-0.1.ebuild
parentAdded eutils to inherit line and made games last. (diff)
downloadgentoo-2-c8196bfce18765e9ab7379789c9262470dd9aea1.tar.gz
gentoo-2-c8196bfce18765e9ab7379789c9262470dd9aea1.tar.bz2
gentoo-2-c8196bfce18765e9ab7379789c9262470dd9aea1.zip
Initial commit of a static /dev ebuild.
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'sys-fs/static-dev/static-dev-0.1.ebuild')
-rw-r--r--sys-fs/static-dev/static-dev-0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/static-dev/static-dev-0.1.ebuild b/sys-fs/static-dev/static-dev-0.1.ebuild
new file mode 100644
index 000000000000..0ee900b47e72
--- /dev/null
+++ b/sys-fs/static-dev/static-dev-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2005-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/static-dev/static-dev-0.1.ebuild,v 1.1 2006/03/20 22:01:10 johnm Exp $
+
+DESCRIPTION="A skeleton, statically managed /dev"
+HOMEPAGE="http://bugs.gentoo.org/show_bug.cgi?id=107875"
+SRC_URI=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sparc"
+IUSE=""
+RDEPEND="virtual/baselayout"
+PROVIDE="virtual/dev-manager"
+
+pkg_postinst() {
+ local x="generic"
+ local makedev
+
+ cd "${ROOT}/dev/" || die "Unable to descend into ${ROOT}/dev/"
+
+ for arch in alpha arm hppa ia64 m68k mips s390 sparc; do
+ use ${arch} && x="${x} generic-${arch}"
+ done
+
+ [[ "${CHOST:0:7}" == "mipsel-" ]] && x="${x} generic-mipsel"
+
+ ( use x86 || use amd64 ) && x="${x} generic-i386"
+ ( use ppc || use ppc64 ) && x="${x} generic-powerpc"
+
+ [[ -e ${ROOT}/dev/MAKEDEV ]] && makedev="${ROOT}/dev/MAKEDEV" || makedev="/dev/MAKEDEV"
+
+ einfo "Making device nodes for ${x}"
+ sh ${makedev} ${x} || die "No ${makedev}?"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ :
+}