summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-13 23:41:42 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-13 23:41:42 +0000
commit7fafa4a562a97e9ac50eaf0cf93204af8a062f4e (patch)
tree11968def161eb1b670308e6e8c657cd6d5ee4380 /sys-fs/xfsdump
parentRespect LDFLAGS while linking the library. (diff)
downloadgentoo-2-7fafa4a562a97e9ac50eaf0cf93204af8a062f4e.tar.gz
gentoo-2-7fafa4a562a97e9ac50eaf0cf93204af8a062f4e.tar.bz2
gentoo-2-7fafa4a562a97e9ac50eaf0cf93204af8a062f4e.zip
Respect LDFLAGS while linking the library.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-fs/xfsdump')
-rw-r--r--sys-fs/xfsdump/ChangeLog6
-rw-r--r--sys-fs/xfsdump/files/xfsdump-2.2.45-LDFLAGS.patch14
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.45.ebuild4
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 6d7540346d63..5514d0a9d38b 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.51 2007/06/03 18:37:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.52 2007/06/13 23:41:42 vapier Exp $
+
+ 13 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsdump-2.2.45-LDFLAGS.patch, xfsdump-2.2.45.ebuild:
+ Respect LDFLAGS while linking the library.
03 Jun 2007; Tobias Scherbaum <dertobi123@gentoo.org>
xfsdump-2.2.45.ebuild:
diff --git a/sys-fs/xfsdump/files/xfsdump-2.2.45-LDFLAGS.patch b/sys-fs/xfsdump/files/xfsdump-2.2.45-LDFLAGS.patch
new file mode 100644
index 000000000000..f5f1ebb74f12
--- /dev/null
+++ b/sys-fs/xfsdump/files/xfsdump-2.2.45-LDFLAGS.patch
@@ -0,0 +1,14 @@
+make sure the library link respects LDFLAGS
+
+http://oss.sgi.com/bugzilla/show_bug.cgi?id=642
+
+--- include/buildmacros
++++ include/buildmacros
+@@ -10,6 +10,7 @@
+ # during the "dist" phase (packaging).
+
+ LDFLAGS += $(LOADERFLAGS) $(LLDFLAGS)
++LTLDFLAGS += $(LOADERFLAGS)
+ LDLIBS = $(LLDLIBS) $(PLDLIBS) $(MALLOCLIB)
+
+ MAKEOPTS = --no-print-directory
diff --git a/sys-fs/xfsdump/xfsdump-2.2.45.ebuild b/sys-fs/xfsdump/xfsdump-2.2.45.ebuild
index 10dccd6e50d4..4b54159d952b 100644
--- a/sys-fs/xfsdump/xfsdump-2.2.45.ebuild
+++ b/sys-fs/xfsdump/xfsdump-2.2.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.45.ebuild,v 1.5 2007/06/03 18:37:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.45.ebuild,v 1.6 2007/06/13 23:41:42 vapier Exp $
inherit eutils autotools
@@ -22,7 +22,7 @@ DEPEND="sys-fs/e2fsprogs
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.2.33-no-compress-docs.patch
+ epatch "${FILESDIR}"/${PN}-2.2.45-LDFLAGS.patch
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
-e '/^GCFLAGS/s:-O1::' \