summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-07-14 12:16:09 +0000
committerRichard Yao <ryao@gentoo.org>2013-07-14 12:16:09 +0000
commite745317f72522e27025c67aa4614856f6a0ff3e1 (patch)
tree9b82aeed6f16a78f4535ddacdb725ffc423024bb /sys-fs/zfs/zfs-9999.ebuild
parentuse subslot operator for boost (diff)
downloadgentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.tar.gz
gentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.tar.bz2
gentoo-2-e745317f72522e27025c67aa4614856f6a0ff3e1.zip
Add modification to systemd init file: use RemainAfterExit=yes instead of true
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 8195b497c509..958855de5461 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.45 2013/07/14 11:52:50 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.46 2013/07/14 12:16:09 ryao Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -72,6 +72,15 @@ src_prepare() {
then
# Fix OpenRC dependencies
epatch "${FILESDIR}/${P}-gentoo-openrc-dependencies.patch"
+
+ # Make zvol initialization asynchronous
+ epatch "${FILESDIR}/${P}-fix-zvol-initialization-r1.patch"
+
+ # Use MAXPATHLEN to silence GCC 4.8 warning
+ epatch "${FILESDIR}/${P}-fix-gcc-4.8-warning.patch"
+
+ # Avoid zdb abort
+ epatch "${FILESDIR}/${P}-avoid-zdb-abort.patch"
fi
# Update paths