summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-09-18 14:49:13 +0000
committerThomas Sachau <tommy@gentoo.org>2009-09-18 14:49:13 +0000
commit4ad8a0d56b45439091712c6f7fae956c00433055 (patch)
tree33dfbe345effecec742e23cd8acf5aaf6cb8611a /sys-fs
parentRemove old version using built_with_use. (diff)
downloadgentoo-2-4ad8a0d56b45439091712c6f7fae956c00433055.tar.gz
gentoo-2-4ad8a0d56b45439091712c6f7fae956c00433055.tar.bz2
gentoo-2-4ad8a0d56b45439091712c6f7fae956c00433055.zip
Version bump (bug #285241), also change metadata.xml, i take over proxy-maintainership since genstef is away
(Portage version: 2.2_rc40-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmraid/ChangeLog9
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild78
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch11
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc16-undo-p-rename.patch13
-rw-r--r--sys-fs/dmraid/metadata.xml9
5 files changed, 117 insertions, 3 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
index 0f308b6e0042..77506f739e07 100644
--- a/sys-fs/dmraid/ChangeLog
+++ b/sys-fs/dmraid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/dmraid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.20 2009/09/10 16:42:57 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.21 2009/09/18 14:49:12 tommy Exp $
+
+*dmraid-1.0.0_rc16 (18 Sep 2009)
+
+ 18 Sep 2009; Ian Stakenvicius (_AxS_) <ian@aerobiology.ca>
+ +dmraid-1.0.0_rc16.ebuild, +files/dmraid-1.0.0_rc16-as-needed.patch,
+ +files/dmraid-1.0.0_rc16-undo-p-rename.patch, metadata.xml:
+ Version bump (bug #285241)
10 Sep 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+files/dmraid-1.0.0_rc15-devsk-isw.patch,
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild
new file mode 100644
index 000000000000..45f4d4a7a074
--- /dev/null
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild,v 1.1 2009/09/18 14:49:12 tommy Exp $
+
+EAPI="2"
+
+inherit linux-info flag-o-matic
+
+MY_PV=${PV/_/.}
+
+DESCRIPTION="Device-mapper RAID tool and library"
+HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
+SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static selinux"
+
+RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
+ sys-fs/device-mapper )
+ selinux? ( sys-libs/libselinux
+ sys-libs/libsepol )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}/${MY_PV}
+
+pkg_setup() {
+ if kernel_is lt 2 6 ; then
+ ewarn "You are using a kernel < 2.6"
+ ewarn "DMraid uses recently introduced Device-Mapper features."
+ ewarn "These might be unavailable in the kernel you are running now."
+ fi
+ if use static && use selinux ; then
+ eerror "ERROR - cannot compile static with libselinux / libsepol"
+ die "USE flag conflicts."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-undo-p-rename.patch \
+ "${FILESDIR}"/${PN}-destdir-fix.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+
+ # archive the patched source for use with genkernel
+ cd "${WORKDIR}"
+ tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static static_link) \
+ $(use_enable selinux libselinux) \
+ $(use_enable selinux libsepol)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2 || die
+}
+
+pkg_postinst() {
+ elog "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
+ elog " "
+ elog "Genkernel will generate the kernel and the initrd with a statically "
+ elog "linked dmraid binary (its own version which may not be the same as this version):"
+ elog "\t emerge -av sys-kernel/genkernel"
+ elog "\t genkernel --dmraid all"
+ elog " "
+ elog "If you would rather use this version of DMRAID with Genkernel, update the following"
+ elog "in /etc/genkernel.conf:"
+ elog "\t DMRAID_VER=\"${MY_PV}\""
+ elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
+ elog " "
+ ewarn "DMRAID should be safe to use, but no warranties can be given"
+}
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch
new file mode 100644
index 000000000000..b7c0c8b4b990
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch
@@ -0,0 +1,11 @@
+--- 1.0.0.rc16/make.tmpl.in 2009-09-17 17:40:28.000000000 -0400
++++ 1.0.0.rc16/make.tmpl.in.new 2009-09-17 17:52:40.000000000 -0400
+@@ -136,7 +136,7 @@
+
+ %.so: $(OBJECTS)
+ $(CC) -shared -Wl,-soname,$(notdir $@).$(DMRAID_LIB_VERSION) \
+- -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event
++ -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event -ldl
+
+ $(LIB_STATIC): $(OBJECTS)
+ $(RM) $@ \ No newline at end of file
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-undo-p-rename.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-undo-p-rename.patch
new file mode 100644
index 000000000000..6636b0563086
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-undo-p-rename.patch
@@ -0,0 +1,13 @@
+Author: Giuseppe Iuculano <giuseppe@iuculano.it>
+Description: Removed "p" from device name. A proper upgrade script is needed before using it.
+--- a/1.0.0.rc15/lib/format/partition/dos.c
++++ b/1.0.0.rc15/lib/format/partition/dos.c
+@@ -31,7 +31,7 @@ _name(struct lib_context *lc, struct rai
+ {
+ const char *base = get_basename(lc, rd->di->path);
+
+- return type ? snprintf(str, len, "%s%s%u", base, OPT_STR_PARTCHAR(lc),
++ return type ? snprintf(str, len, "%s%u", base,
+ partition) : snprintf(str, len, "%s", base);
+ }
+
diff --git a/sys-fs/dmraid/metadata.xml b/sys-fs/dmraid/metadata.xml
index 481ec8a52d9a..7879ce6c954a 100644
--- a/sys-fs/dmraid/metadata.xml
+++ b/sys-fs/dmraid/metadata.xml
@@ -4,8 +4,13 @@
<herd>no-herd</herd>
<maintainer>
<email>ian@aerobiology.ca</email>
- <description>Indirectly maintaining through
- genstef@gentoo.org</description>
+ <name>Ian Stakenvicius</name>
+ <description>Maintainer of ebuilds, assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>tommy@gentoo.org</email>
+ <name>Thomas Sachau</name>
+ <description>Proxy committer, CC bugs</description>
</maintainer>
<longdescription>This software discovers, activates, deactivates and displays properties of software RAID sets eg: ATARAID and contained DOS partitions.</longdescription>
</pkgmetadata>