summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-12-05 14:46:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-12-05 14:46:57 +0000
commit6a29c274a36123de698227eaa8dea28b9fbc9214 (patch)
tree286906765f631714e3651cae4d05ca2ad9b4aeb9 /sys-fs
parentBump to 1.5.8 (still masked) for gnome-shell and remove 1.4 which is now unused (diff)
downloadgentoo-2-6a29c274a36123de698227eaa8dea28b9fbc9214.tar.gz
gentoo-2-6a29c274a36123de698227eaa8dea28b9fbc9214.tar.bz2
gentoo-2-6a29c274a36123de698227eaa8dea28b9fbc9214.zip
Fix up ebuild and building on Darwin, drop unnecessary stuff
(Portage version: 2.2.01.17304-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog7
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild10
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch35
3 files changed, 7 insertions, 45 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index ba15ffff73c0..4026f97a0ddc 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.228 2010/12/05 12:51:13 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.229 2010/12/05 14:46:57 grobian Exp $
+
+ 05 Dec 2010; Fabian Groffen <grobian@gentoo.org>
+ e2fsprogs-1.41.12-r1.ebuild,
+ -files/e2fsprogs-1.41.12-darwin-no-mntent.patch:
+ Fix up ebuild and building on Darwin, drop unnecessary stuff
05 Dec 2010; Fabian Groffen <grobian@gentoo.org>
files/e2fsprogs-1.41.12-darwin-makefile.patch,
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild
index 968798a91ff5..73635ff82057 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild,v 1.3 2010/12/04 22:29:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.41.12-r1.ebuild,v 1.4 2010/12/05 14:46:57 grobian Exp $
EAPI="3"
@@ -41,7 +41,6 @@ src_prepare() {
-e 's:$(LN) -f $(DESTDIR).*/:$(LN_S) -f :' \
{e2fsck,misc}/Makefile.in || die
epatch "${FILESDIR}"/${P}-darwin-makefile.patch
- epatch "${FILESDIR}"/${P}-darwin-no-mntent.patch
if [[ ${CHOST} == *-mint* ]] ; then
epatch "${FILESDIR}"/${PN}-1.41-mint.patch
epatch "${FILESDIR}"/${PN}-1.41.7-mint-blkid.patch
@@ -77,13 +76,6 @@ src_configure() {
*) libtype=--enable-elf-shlibs ;;
esac
- # On MacOSX 10.4 using the assembly built-in bitoperation functions causes
- # segmentation faults. Though this is likely fixable we can quickly make it
- # at least work by using the C functions.
- if [[ ${CHOST} == i?86-apple-darwin* ]]; then
- append-flags -D_EXT2_USE_C_VERSIONS_
- fi
-
ac_cv_path_LDCONFIG=: \
econf \
--with-root-prefix="${EPREFIX}/" \
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch
deleted file mode 100644
index 91ffb2c0ef94..000000000000
--- a/sys-fs/e2fsprogs/files/e2fsprogs-1.41.12-darwin-no-mntent.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Dirk Tilger <dirk@miriup.de>:
- For the mntent.patch: e2fsprogs is using a GNU libc specific
- operation: setmntent and endmntent. Both operate on /etc/mtab, which
- doesn't exist on MacOSX, thus they are simply not called on
- Darwin.
-
-http://bugs.gentoo.org/show_bug.cgi?id=263841
-
-diff --git a/misc/ismounted.c b/misc/ismounted.c
-index 50b4140..84579a4 100644
---- a/misc/ismounted.c
-+++ b/misc/ismounted.c
-@@ -86,8 +86,10 @@ static errcode_t check_mntent_file(const char *mtab_file, const char *file,
- char buf[1024], *device = 0, *mnt_dir = 0, *cp;
-
- *mount_flags = 0;
-+ #ifndef __APPLE__
- if ((f = setmntent (mtab_file, "r")) == NULL)
- return errno;
-+ #endif
- if (stat(file, &st_buf) == 0) {
- if (S_ISBLK(st_buf.st_mode)) {
- #ifndef __GNU__ /* The GNU hurd is broken with respect to stat devices */
-@@ -175,7 +177,11 @@ static errcode_t check_mntent_file(const char *mtab_file, const char *file,
-
- retval = 0;
- errout:
-+ #ifdef __APPLE__
-+ fclose (f);
-+ #else
- endmntent (f);
-+ #endif
- return retval;
- #else /* !HAVE_MNTENT_H */
- return 0;