summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-01-02 16:26:32 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-01-02 16:26:32 +0000
commita7d9b9df6bb3fd39479cc19c6fd959a9901d9835 (patch)
treeb04d794ac8c5b8aab8a5bc876255af1c3c3dc8dd /sys-fs
parentVersion bump to RC version of 4.2 release. (Manifest recommit) (diff)
downloadgentoo-2-a7d9b9df6bb3fd39479cc19c6fd959a9901d9835.tar.gz
gentoo-2-a7d9b9df6bb3fd39479cc19c6fd959a9901d9835.tar.bz2
gentoo-2-a7d9b9df6bb3fd39479cc19c6fd959a9901d9835.zip
Back to the old fuse-1.4.ebuild, 1.4 has obviously a more broken build-system than 2.1 and therefore does not work with linux-mod
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/fuse-1.4.ebuild40
2 files changed, 31 insertions, 15 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 5eced7dd50b1..ecf7b0c43ae2 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.6 2005/01/01 23:04:39 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.7 2005/01/02 16:26:32 genstef Exp $
+
+ 02 Jan 2005; Stefan Schweizer <genstef@gentoo.org> fuse-1.4.ebuild:
+ Back to the old fuse-1.4.ebuild, 1.4 has obviously a more broken
+ build-system than 2.1 and therefore does not work with linux-mod
02 Jan 2005; Stefan Schweizer <genstef@gentoo.org> :
Version 1.4 stable on x86
diff --git a/sys-fs/fuse/fuse-1.4.ebuild b/sys-fs/fuse/fuse-1.4.ebuild
index 178d106186e6..8430a986dbd4 100644
--- a/sys-fs/fuse/fuse-1.4.ebuild
+++ b/sys-fs/fuse/fuse-1.4.ebuild
@@ -1,41 +1,53 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-1.4.ebuild,v 1.3 2005/01/01 23:01:06 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-1.4.ebuild,v 1.4 2005/01/02 16:26:32 genstef Exp $
-inherit linux-mod
+inherit kernel-mod
MY_P=${P/_/-}
DESCRIPTION="An interface for filesystems implemented in userspace."
HOMEPAGE="http://sourceforge.net/projects/fuse"
SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE=""
S=${WORKDIR}/${MY_P}
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
-BUILD_TARGETS="all"
+DEPEND="virtual/linux-sources"
+
+pkg_setup() {
+ kernel-mod_check_modules_supported
+}
src_compile() {
- econf --disable-kernel-module --disable-example || die "econf failed"
- emake || die "emake failed"
+ econf --disable-example --with-kernel="${ROOT}/usr/src/linux" || die "econf failed"
+
+ sed -i 's/.*depmod.*//' kernel/Makefile
- cd kernel
- econf --with-kernel="${ROOT}${KV_DIR}" || die "econf kernel failed"
- sed -i 's/.*depmod.*//' Makefile
- convert_to_m Makefile
- linux-mod_src_compile
+ # http://marc.theaimsgroup.com/?l=gentoo-dev&m=109672618708314&w=2
+ kernel-mod_getversion
+ if [ ${KV_MINOR} -gt 5 ] && [ ${KV_PATCH} -gt 5 ]
+ then
+ sed -i 's:SUBDIRS=:M=:g' kernel/Makefile
+ fi
+
+ unset ARCH
+ emake || die "emake failed"
}
src_install() {
+ unset ARCH
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog Filesystems README README-2.4 \
README-2.6 README.NFS NEWS doc/how-fuse-works
docinto example
dodoc example/*
+}
- linux-mod_src_install
+pkg_postinst() {
+ einfo "Checking kernel module dependencies"
+ test -r "${ROOT}/usr/src/linux/System.map" && \
+ depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
}