summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-08 11:55:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-08 11:55:49 +0000
commitae50070f0d4a764ec453a4d00c1b52336c08e825 (patch)
tree8c79432906af3b67415eff3e513722ec0f3b6906 /sys-fs
parentStable for sh, wrt bug #455930 (diff)
downloadgentoo-2-ae50070f0d4a764ec453a4d00c1b52336c08e825.tar.gz
gentoo-2-ae50070f0d4a764ec453a4d00c1b52336c08e825.tar.bz2
gentoo-2-ae50070f0d4a764ec453a4d00c1b52336c08e825.zip
Update live ebuild to use new --root switch from git for hwdb --update. Remove target systemd-install-hook (and udev-confdirs) to match current git. This will mean content of /usr/lib/systemd/system/sysinit.target.wants/ is not installed with udev anymore.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog8
-rw-r--r--sys-fs/udev/udev-9999.ebuild17
2 files changed, 14 insertions, 11 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index 1f6607f6fffb..10d9156e7ce1 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.821 2013/02/07 18:50:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.822 2013/02/08 11:55:49 ssuominen Exp $
+
+ 08 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> udev-9999.ebuild:
+ Update live ebuild to use new --root switch from git for hwdb --update.
+ Remove target systemd-install-hook (and udev-confdirs) to match current git.
+ This will mean content of /usr/lib/systemd/system/sysinit.target.wants/ is
+ not installed with udev anymore.
*udev-197-r8 (07 Feb 2013)
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index e65dc7a434fe..47471512341a 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.172 2013/02/07 18:05:03 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.173 2013/02/08 11:55:49 ssuominen Exp $
EAPI=4
-KV_min=2.6.39
+KV_min=2.6.32
inherit autotools eutils linux-info multilib systemd toolchain-funcs versionator
@@ -18,7 +18,8 @@ else
if [[ -n "${patchset}" ]]
then
SRC_URI="${SRC_URI}
- http://dev.gentoo.org/~williamh/dist/${P}-patches-${patchset}.tar.bz2"
+ http://dev.gentoo.org/~williamh/dist/${P}-patches-${patchset}.tar.bz2
+ http://dev.gentoo.org/~ssuominen/${P}-patches-${patchset}.tar.bz2"
fi
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -77,8 +78,6 @@ QA_MULTILIB_PATHS="lib/systemd/systemd-udevd"
udev_check_KV()
{
- # accept4 came late for ia64
- use ia64 && KV_min=3.3
if kernel_is lt ${KV_min//./ }
then
return 1
@@ -176,13 +175,13 @@ src_prepare()
if [[ ${PV} = 9999* ]]; then
# secure_getenv() disable for non-glibc systems wrt bug #443030
- if ! [[ $(grep -r secure_getenv * | wc -l) -eq 13 ]]; then
+ if ! [[ $(grep -r secure_getenv * | wc -l) -eq 23 ]]; then
eerror "The line count for secure_getenv() failed, see bug #443030"
die
fi
# gperf disable if keymaps are not requested wrt bug #452760
- if ! [[ $(grep -i gperf Makefile.am | wc -l) -eq 24 ]]; then
+ if ! [[ $(grep -i gperf Makefile.am | wc -l) -eq 27 ]]; then
eerror "The line count for gperf references failed, see bug 452760"
die
fi
@@ -307,8 +306,6 @@ src_install()
install-sharepkgconfigDATA
install-typelibsDATA
install-dist_docDATA
- udev-confdirs
- systemd-install-hook
libudev-install-hook
libsystemd-daemon-install-hook
install-pkgincludeHEADERS
@@ -524,5 +521,5 @@ pkg_postinst()
elog " fixing known issues visit:"
elog " http://www.gentoo.org/doc/en/udev-guide.xml"
- use hwdb && udevadm hwdb --update
+ use hwdb && udevadm hwdb --update --root="${ROOT%/}"
}