summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-11 19:08:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-11 19:08:25 +0000
commitb3a2e2fe8ea6593c27a89dc942065124659cf600 (patch)
tree6f36eeef1976e1e24a304dbaff02ceb512613783 /sys-fs
parentversion bump + fix bug #370609 (diff)
downloadgentoo-2-b3a2e2fe8ea6593c27a89dc942065124659cf600.tar.gz
gentoo-2-b3a2e2fe8ea6593c27a89dc942065124659cf600.tar.bz2
gentoo-2-b3a2e2fe8ea6593c27a89dc942065124659cf600.zip
Move udev rules from /etc/udev/rules.d to /lib/udev/rules.d. Enable USE="ntfsprogs" by default wrt #384865. Create mount.ntfs symlink wrt #374197 by Claudio Roberto França Pereira. Move everything to /usr wrt #398069 by Michał Górny.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog11
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild76
2 files changed, 86 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 4a6ad00f2ec5..870c1aed6a1f 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.121 2012/01/23 18:32:01 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.122 2012/03/11 19:08:25 ssuominen Exp $
+
+*ntfs3g-2012.1.15-r1 (11 Mar 2012)
+
+ 11 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +ntfs3g-2012.1.15-r1.ebuild:
+ Move udev rules from /etc/udev/rules.d to /lib/udev/rules.d. Enable
+ USE="ntfsprogs" by default wrt #384865. Create mount.ntfs symlink wrt #374197
+ by Claudio Roberto França Pereira. Move everything to /usr wrt #398069 by
+ Michał Górny.
*ntfs3g-2012.1.15 (23 Jan 2012)
diff --git a/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild
new file mode 100644
index 000000000000..f2ad455c609a
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2012.1.15-r1.ebuild,v 1.1 2012/03/11 19:08:25 ssuominen Exp $
+
+EAPI=4
+inherit linux-info
+
+MY_PN=${PN/3g/-3g}
+MY_P=${MY_PN}_ntfsprogs-${PV}
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
+SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl crypt debug extras +ntfsprogs suid static-libs xattr +udev +external-fuse"
+
+RDEPEND="external-fuse? ( >=sys-fs/fuse-2.8.0 )
+ ntfsprogs? ( !!sys-fs/ntfsprogs )
+ crypt? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-apps/attr"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS ChangeLog CREDITS README"
+
+pkg_setup() {
+ if use external-fuse && use kernel_linux; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --exec-prefix=/usr \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-ldscript \
+ --disable-ldconfig \
+ --with-fuse=$(use external-fuse && echo external || echo internal) \
+ $(use_enable acl posix-acls) \
+ $(use_enable crypt crypto) \
+ $(use_enable extras) \
+ $(use_enable ntfsprogs) \
+ $(use_enable static-libs static) \
+ $(use_enable xattr xattr-mappings) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ use suid && fperms u+s /bin/${MY_PN}
+
+ if use udev; then
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}"/99-ntfs3g.rules
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # http://bugs.gentoo.org/398069
+ dodir /usr/sbin
+ mv -vf "${ED}"/sbin/* "${ED}"/usr/sbin || die
+ rm -rf "${ED}"/sbin
+
+ dosym mount.ntfs-3g /usr/sbin/mount.ntfs #374197
+}