summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-12 13:50:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-12 13:50:35 +0000
commitb691b9fd3fe15fefa668c8f80b9f37fb402f6927 (patch)
tree0af6f5e432952302813efb661e4e39596c8693ba /sys-fs
parentvanilla-3.10.5 + genpatches-3.10-10 + grsecurity-2.9.1-3.10.5-201308091415 (diff)
downloadgentoo-2-b691b9fd3fe15fefa668c8f80b9f37fb402f6927.tar.gz
gentoo-2-b691b9fd3fe15fefa668c8f80b9f37fb402f6927.tar.bz2
gentoo-2-b691b9fd3fe15fefa668c8f80b9f37fb402f6927.zip
Only reload the hwdb.bin when we are not upgrading to avoid potential race w/ incompatible hwdb.bin and the running udevd.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog7
-rw-r--r--sys-fs/udev/udev-206-r3.ebuild13
-rw-r--r--sys-fs/udev/udev-9999.ebuild13
3 files changed, 22 insertions, 11 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index e3db0dde9d4a..73e03771bf3e 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.955 2013/08/11 19:01:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.956 2013/08/12 13:50:35 ssuominen Exp $
+
+ 12 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> udev-206-r3.ebuild,
+ udev-9999.ebuild:
+ Only reload the hwdb.bin when we are not upgrading to avoid potential race w/
+ incompatible hwdb.bin and the running udevd.
11 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> udev-206-r3.ebuild,
udev-9999.ebuild:
diff --git a/sys-fs/udev/udev-206-r3.ebuild b/sys-fs/udev/udev-206-r3.ebuild
index e59760ea4342..6ac4ba70d98d 100644
--- a/sys-fs/udev/udev-206-r3.ebuild
+++ b/sys-fs/udev/udev-206-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-206-r3.ebuild,v 1.4 2013/08/11 19:01:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-206-r3.ebuild,v 1.5 2013/08/12 13:50:35 ssuominen Exp $
EAPI=5
@@ -513,10 +513,13 @@ pkg_postinst() {
# Update hwdb database in case the format is changed by udev version.
if has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
- # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
+ # Only reload when we are not upgrading to avoid potential race w/ incompatible hwdb.bin and the running udevd
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
fi
- udevadm control --reload
fi
}
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 4b84896640c0..c3ae8042775a 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.250 2013/08/11 19:01:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.251 2013/08/12 13:50:35 ssuominen Exp $
EAPI=5
@@ -513,10 +513,13 @@ pkg_postinst() {
# Update hwdb database in case the format is changed by udev version.
if has_version 'sys-apps/hwids[udev]'; then
udevadm hwdb --update --root="${ROOT%/}"
- # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
+ # Only reload when we are not upgrading to avoid potential race w/ incompatible hwdb.bin and the running udevd
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ # http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
fi
- udevadm control --reload
fi
}