summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-12-26 19:07:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-12-26 19:07:24 +0000
commitc582460d44d43c3107cbfabc333e926e3acad1d0 (patch)
treec8698ead6a35be4186367ee935278ac363aa026c /sys-fs
parentfix multilib-strict wise (diff)
downloadgentoo-2-c582460d44d43c3107cbfabc333e926e3acad1d0.tar.gz
gentoo-2-c582460d44d43c3107cbfabc333e926e3acad1d0.tar.bz2
gentoo-2-c582460d44d43c3107cbfabc333e926e3acad1d0.zip
version bump, closes #98137
(Portage version: 2.1_pre2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/captive/ChangeLog7
-rw-r--r--sys-fs/captive/Manifest6
-rw-r--r--sys-fs/captive/captive-1.1.6.ebuild85
-rw-r--r--sys-fs/captive/files/digest-captive-1.1.61
4 files changed, 96 insertions, 3 deletions
diff --git a/sys-fs/captive/ChangeLog b/sys-fs/captive/ChangeLog
index 486c62e1a189..40448e76346e 100644
--- a/sys-fs/captive/ChangeLog
+++ b/sys-fs/captive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/captive
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.7 2005/08/23 13:10:28 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.8 2005/12/26 19:07:24 genstef Exp $
+
+*captive-1.1.6 (26 Dec 2005)
+
+ 26 Dec 2005; Stefan Schweizer <genstef@gentoo.org> +captive-1.1.6.ebuild:
+ version bump, closes #98137
23 Aug 2005; Stefan Schweizer <genstef@gentoo.org>
captive-1.1.5-r2.ebuild:
diff --git a/sys-fs/captive/Manifest b/sys-fs/captive/Manifest
index 27f4d25ec306..499899bfe874 100644
--- a/sys-fs/captive/Manifest
+++ b/sys-fs/captive/Manifest
@@ -1,7 +1,9 @@
+MD5 0bfbba7d90d531c9382b900efa653569 ChangeLog 2312
MD5 e713979a7c0acc2e3f22f790a59bd5eb captive-1.1.5-r2.ebuild 2806
-MD5 8c84d819d5e001a5d9e39d2da3466b68 ChangeLog 2175
-MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
+MD5 d7c92df6ecce5cbef25d28b2a5346d20 captive-1.1.6.ebuild 2189
MD5 09de72e8ea997c51e2cdd999343d63ac files/add-extra-opts-for-user-access-to-mount-t-captive.patch 647
MD5 00da6b972db84ffd52c945b07c3204d4 files/digest-captive-1.1.5-r2 148
+MD5 08d428f29220c44d67ab40deb8eca20d files/digest-captive-1.1.6 69
MD5 af3ab379ab00c1a99eaaa24e67007377 files/do-not-check-for-lufsd.patch 1090
MD5 ec2f404ce7a254d2d75101c257fdd9ce files/use-lufis-for-mount-t-captive.patch 1041
+MD5 6e89ba8198764bfd079a0cfa18dca593 metadata.xml 264
diff --git a/sys-fs/captive/captive-1.1.6.ebuild b/sys-fs/captive/captive-1.1.6.ebuild
new file mode 100644
index 000000000000..73ad952aa133
--- /dev/null
+++ b/sys-fs/captive/captive-1.1.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.6.ebuild,v 1.1 2005/12/26 19:07:24 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Captive uses binary Windows drivers for full NTFS r/w access."
+HOMEPAGE="http://www.jankratochvil.net/project/captive/"
+SRC_URI="http://www.jankratochvil.net/priv/captive/${P}cvs.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+
+IUSE="debug"
+
+RDEPEND="sys-libs/readline
+ >=gnome-base/orbit-2.8.2
+ gnome-base/gnome-vfs
+ dev-libs/popt
+ dev-libs/glib
+ >=dev-libs/openssl-0.9.7c
+ >=dev-libs/libxml2-2.4.29
+ >=sys-fs/fuse-2.2"
+
+DEPEND="${RDEPEND}
+ sys-fs/ntfsprogs"
+
+S=${WORKDIR}/${P}cvs
+
+pkg_setup() {
+ einfo "Adding captive user and group"
+ enewgroup captive || die "enewgroup captive failed"
+ enewuser captive -1 -1 /dev/null captive || die "enewuser captive failed"
+}
+
+src_compile() {
+ # disable some tests to save time ;)
+ econf `use_enable debug bug-replay` \
+ --disable-static \
+ --with-readline \
+ --disable-lufs \
+ --enable-fuse \
+ --enable-sandbox-setuid=captive \
+ --enable-sandbox-setgid=captive \
+ --enable-sandbox-chroot=/var/lib/captive \
+ --enable-man-pages \
+ --enable-sbin-mountdir=/sbin \
+ --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
+ --disable-gtk-doc \
+ --with-orbit-line=link \
+ --disable-glibtest --disable-orbittest \
+ --with-tmpdir=/tmp --localstatedir=/var || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodir /var/lib/captive
+ diropts -m1777
+ dodir /var/lib/captive/tmp
+ keepdir /var/lib/captive/tmp
+
+ rm -R ${D}/etc/rc.d
+
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ einfo "Use /usr/sbin/captive-install-acquire to search for and"
+ einfo "install the needed drivers for captive NTFS."
+ einfo ""
+ einfo "Please use \"mount -t captive-ntfs /dev/hda1 /mnt/ntfs\" to mount ntfs partitions."
+}
+
+pkg_postrm() {
+ #einfo Removing captive user
+ #userdel captive
+ #einfo Removing captive group
+ #groupdel captive
+ einfo ""
+ einfo "You will have to remove captive user and group manually"
+ einfo ""
+}
diff --git a/sys-fs/captive/files/digest-captive-1.1.6 b/sys-fs/captive/files/digest-captive-1.1.6
new file mode 100644
index 000000000000..2ec670843120
--- /dev/null
+++ b/sys-fs/captive/files/digest-captive-1.1.6
@@ -0,0 +1 @@
+MD5 537ea7cab112b34ee7b8880f6b0fe34e captive-1.1.6cvs.tar.gz 3535636