summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-01-11 06:13:59 +0000
committerRichard Yao <ryao@gentoo.org>2013-01-11 06:13:59 +0000
commitda8e872eba368d32aa4882bb566391b995d6ad2f (patch)
treea37ec8d3704d324839ed8113833436be7ae662a0 /sys-fs
parentBump for #451256 (diff)
downloadgentoo-2-da8e872eba368d32aa4882bb566391b995d6ad2f.tar.gz
gentoo-2-da8e872eba368d32aa4882bb566391b995d6ad2f.tar.bz2
gentoo-2-da8e872eba368d32aa4882bb566391b995d6ad2f.zip
Synchronize zfs-9999.ebuild with zfs-0.6.0_rc13-r1.ebuild, bug #451016. Thanks Marcin
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/ChangeLog6
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild22
2 files changed, 14 insertions, 14 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index 69a0a0982f65..8723986b294a 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.54 2013/01/05 16:21:37 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.55 2013/01/11 06:13:59 ryao Exp $
+
+ 11 Jan 2013; Richard Yao <ryao@gentoo.org> zfs-9999.ebuild:
+ Synchronize zfs-9999.ebuild with zfs-0.6.0_rc13-r1.ebuild, bug #451016. Thanks
+ Marcin
*zfs-0.6.0_rc13-r1 (05 Jan 2013)
*zfs-0.6.0_rc11-r2 (05 Jan 2013)
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index fdc762b92763..10d9d7a9264b 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.39 2012/12/03 02:03:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.40 2013/01/11 06:13:59 ryao Exp $
EAPI="4"
@@ -16,8 +16,8 @@ if [ ${PV} == "9999" ] ; then
else
inherit eutils versionator
MY_PV=$(replace_version_separator 3 '-')
- SRC_URI="https://github.com/downloads/zfsonlinux/${PN}/${PN}-${MY_PV}.tar.gz"
- S="${WORKDIR}/${PN}-${MY_PV}"
+ SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
KEYWORDS="~amd64"
fi
@@ -86,13 +86,6 @@ src_install() {
rm -rf "${ED}usr/share/dracut"
use test-suite || rm -rf "${ED}usr/libexec"
- if use rootfs
- then
- doinitd "${FILESDIR}/zfs-shutdown"
- exeinto /usr/share/zfs
- doexe "${FILESDIR}/linuxrc"
- fi
-
newbashcomp "${FILESDIR}/bash-completion" zfs
}
@@ -102,7 +95,10 @@ pkg_postinst() {
[ -e "${EROOT}/etc/runlevels/boot/zfs" ] \
|| ewarn 'You should add zfs to the boot runlevel.'
- use rootfs && ([ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ] \
- || ewarn 'You should add zfs-shutdown to the shutdown runlevel.')
+ if [ -e "${EROOT}/etc/runlevels/shutdown/zfs-shutdown" ]
+ then
+ einfo "The zfs-shutdown script is obsolete. Removing it from runlevel."
+ rm "${EROOT}/etc/runlevels/shutdown/zfs-shutdown"
+ fi
}