summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-08-10 21:45:27 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-08-10 21:45:27 +0000
commitf07ffc9e60a38fac1cfc37deba04f528178abc83 (patch)
tree15ca0eda0ca4958e1edfeef00599ac009f83d836 /sys-fs
parentconvert to multilib (diff)
downloadgentoo-2-f07ffc9e60a38fac1cfc37deba04f528178abc83.tar.gz
gentoo-2-f07ffc9e60a38fac1cfc37deba04f528178abc83.tar.bz2
gentoo-2-f07ffc9e60a38fac1cfc37deba04f528178abc83.zip
Version bump
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/loop-aes/ChangeLog7
-rw-r--r--sys-fs/loop-aes/loop-aes-3.6i.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sys-fs/loop-aes/ChangeLog b/sys-fs/loop-aes/ChangeLog
index 0c2f44763275..8fe0c4fdc609 100644
--- a/sys-fs/loop-aes/ChangeLog
+++ b/sys-fs/loop-aes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/loop-aes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/ChangeLog,v 1.95 2013/07/04 17:34:42 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/ChangeLog,v 1.96 2013/08/10 21:45:27 alonbl Exp $
+
+*loop-aes-3.6i (10 Aug 2013)
+
+ 10 Aug 2013; Alon Bar-Lev <alonbl@gentoo.org> +loop-aes-3.6i.ebuild:
+ Version bump
04 Jul 2013; Alon Bar-Lev <alonbl@gentoo.org> -loop-aes-3.6b-r1.ebuild,
-loop-aes-3.6b.ebuild, -loop-aes-3.6c.ebuild, -loop-aes-3.6d.ebuild,
diff --git a/sys-fs/loop-aes/loop-aes-3.6i.ebuild b/sys-fs/loop-aes/loop-aes-3.6i.ebuild
new file mode 100644
index 000000000000..5c2f780f1b41
--- /dev/null
+++ b/sys-fs/loop-aes/loop-aes-3.6i.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/loop-aes-3.6i.ebuild,v 1.1 2013/08/10 21:45:27 alonbl Exp $
+
+EAPI="3"
+
+inherit linux-mod
+
+MY_P="${PN/aes/AES}-v${PV}"
+
+DESCRIPTION="Linux kernel module to encrypt local file systems and disk partitions with AES cipher."
+HOMEPAGE="http://loop-aes.sourceforge.net/loop-AES.README"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="aes-ni extra-ciphers keyscrub padlock"
+
+DEPEND="|| ( >=sys-apps/util-linux-2.12r[crypt,loop-aes] app-crypt/loop-aes-losetup )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ CONFIG_CHECK="!BLK_DEV_LOOP"
+ MODULE_NAMES="loop(block::tmp-d-kbuild)"
+ BUILD_TARGETS="all"
+
+ BUILD_PARAMS=" \
+ V=1 \
+ LINUX_SOURCE=\"${KERNEL_DIR}\" \
+ KBUILD_OUTPUT=\"${KBUILD_OUTPUT}\" \
+ USE_KBUILD=y MODINST=n RUNDM=n"
+ use aes-ni && BUILD_PARAMS="${BUILD_PARAMS} INTELAES=y"
+ use keyscrub && BUILD_PARAMS="${BUILD_PARAMS} KEYSCRUB=y"
+ use padlock && BUILD_PARAMS="${BUILD_PARAMS} PADLOCK=y"
+
+ if use extra-ciphers; then
+ MODULE_NAMES="${MODULE_NAMES}
+ loop_blowfish(block::tmp-d-kbuild)
+ loop_serpent(block::tmp-d-kbuild)
+ loop_twofish(block::tmp-d-kbuild)"
+ BUILD_PARAMS="${BUILD_PARAMS} EXTRA_CIPHERS=y"
+ fi
+}
+
+src_prepare() {
+ sed -e 's/make/$(MAKE)/g' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README || die "dodoc failed"
+ dobin loop-aes-keygen || die "dobin failed"
+ doman loop-aes-keygen.1 || die "doman failed"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo
+ einfo "For more instructions take a look at examples in README at:"
+ einfo "'${EPREFIX}/usr/share/doc/${PF}'"
+ einfo
+ einfo "If you have a newer Intel processor (i5, i7), and you use AES"
+ einfo "you may want to consider using the aes-ni use flag. It will"
+ einfo "use your processors native AES instructions giving quite a speed"
+ einfo "increase."
+ einfo
+
+ ewarn
+ ewarn "Please consider using loop-aes-losetup package instead of"
+ ewarn "util-linux[loop-aes], it will enable all loop-aes services"
+ ewarn "without patching util-linux package"
+ ewarn
+ ewarn "In future only loop-aes-losetup will be available in portage"
+ ewarn
+}