summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2011-09-14 16:36:22 +0000
committerMike Pagano <mpagano@gentoo.org>2011-09-14 16:36:22 +0000
commitdb884914a0b168ccc206b2947f433b5348c4a6ef (patch)
treeb48f0adc9896ff8da198c2a412f664c926af8ec0 /sys-kernel/git-sources
parentx86 stable, thanks JD, bug 379045 (diff)
downloadgentoo-2-db884914a0b168ccc206b2947f433b5348c4a6ef.tar.gz
gentoo-2-db884914a0b168ccc206b2947f433b5348c4a6ef.tar.bz2
gentoo-2-db884914a0b168ccc206b2947f433b5348c4a6ef.zip
Add new version that now retrieves patch from Linus' github account. Hopefully, this is temporary.
(Portage version: 2.2.0_alpha56/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/ChangeLog8
-rw-r--r--sys-kernel/git-sources/git-sources-3.1_rc5.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index f562e22fb9e8..1ada6cd803f7 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1261 2011/08/31 00:21:32 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1262 2011/09/14 16:36:22 mpagano Exp $
+
+*git-sources-3.1_rc5 (14 Sep 2011)
+
+ 14 Sep 2011; Michael Pagano <mpagano@gentoo.org> +git-sources-3.1_rc5.ebuild:
+ Add new version that now retrieves patch from Linus' github account.
+ Hopefully, this is temporary.
*git-sources-3.1_rc4-r2 (31 Aug 2011)
diff --git a/sys-kernel/git-sources/git-sources-3.1_rc5.ebuild b/sys-kernel/git-sources/git-sources-3.1_rc5.ebuild
new file mode 100644
index 000000000000..f214836dd04a
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.1_rc5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.1_rc5.ebuild,v 1.1 2011/09/14 16:36:22 mpagano Exp $
+
+EAPI="4"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2 git-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+EGIT_REPO_URI="https://github.com/torvalds/linux.git"
+${PN}_LIVE_COMMIT="${PV}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}