summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Luzzardi <scox@gentoo.org>2004-09-08 20:42:21 +0000
committerAndrea Luzzardi <scox@gentoo.org>2004-09-08 20:42:21 +0000
commitde3602321c6ccbc7257c0be6eddf9b36aff83f94 (patch)
treec5573b5e81bcf87818a17322307946b233727bee /sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild
parentFixed socks support, removed dependency on dante. (Manifest recommit) (diff)
downloadgentoo-2-de3602321c6ccbc7257c0be6eddf9b36aff83f94.tar.gz
gentoo-2-de3602321c6ccbc7257c0be6eddf9b36aff83f94.tar.bz2
gentoo-2-de3602321c6ccbc7257c0be6eddf9b36aff83f94.zip
Added h-s-2.4.27-r3 which uses the new 2.4-27.2 patchball (updates grsecurity to its current version, 2.0.1)
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild
new file mode 100644
index 000000000000..9ce8961ed9d7
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.4.27-r3.ebuild,v 1.1 2004/09/08 20:42:21 scox Exp $
+
+IUSE="selinux"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+HGPV=27.2
+HGPV_SRC="http://dev.gentoo.org/~scox/kernels/v2.4/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}.tar.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+
+# According to the patchset numbering scheme, 31xx patches are grsec related
+# while 32xx are SELinux related.
+
+if use selinux; then
+ UNIPATCH_EXCLUDE="31"
+else
+ UNIPATCH_EXCLUDE="32"
+fi
+
+UNIPATCH_LIST=" ${DISTDIR}/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}.tar.bz2 \
+ ${FILESDIR}/${OKV}*.patch"
+
+UNIPATCH_DOCS="${WORKDIR}/patches/hardened-patches-${KV_MAJOR}.${KV_MINOR}-${HGPV}/0000_README"
+
+DESCRIPTION="Hardened sources for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+
+SRC_URI="${KERNEL_URI} ${HGPV_SRC}"
+KEYWORDS="~x86 -ppc"
+
+pkg_postinst() {
+ postinst_sources
+}