summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-09-15 10:06:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-09-15 10:06:28 +0000
commit672e7f5a142f38aebc665471a2ae66b45b5ddbb6 (patch)
tree63f6b45b27df021f88b51e9d995240af275278e7 /sys-kernel/hardened-sources
parentguile-1.8.5-r1 is stable so depend on >=dev-scheme/guile-1.8 and drop built_w... (diff)
downloadgentoo-2-672e7f5a142f38aebc665471a2ae66b45b5ddbb6.tar.gz
gentoo-2-672e7f5a142f38aebc665471a2ae66b45b5ddbb6.tar.bz2
gentoo-2-672e7f5a142f38aebc665471a2ae66b45b5ddbb6.zip
hardened-sources-2.6.32-r17 based on 2.6.32.21 + genpatches + grsec-2.2.0-2.6.32.21-201009130811
hardened-sources-2.6.34-r5 based on 2.6.34.6 + genpatches + grsec-2.2.0-2.6.34.6-201009130754 (Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog12
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r17.ebuild46
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.34-r5.ebuild46
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index b083eeab3016..c6f489134f77 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.336 2010/09/07 09:53:00 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.337 2010/09/15 10:06:28 blueness Exp $
+
+*hardened-sources-2.6.34-r5 (15 Sep 2010)
+*hardened-sources-2.6.32-r17 (15 Sep 2010)
+
+ 15 Sep 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r17.ebuild, +hardened-sources-2.6.34-r5.ebuild:
+ hardened-sources-2.6.32-r17 based on 2.6.32.21 + genpatches +
+ grsec-2.2.0-2.6.32.21-201009130811
+ hardened-sources-2.6.34-r5 based on 2.6.34.6 + genpatches +
+ grsec-2.2.0-2.6.34.6-201009130754
*hardened-sources-2.6.34-r4 (07 Sep 2010)
*hardened-sources-2.6.32-r16 (07 Sep 2010)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r17.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r17.ebuild
new file mode 100644
index 000000000000..e7ff95710170
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r17.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r17.ebuild,v 1.1 2010/09/15 10:06:28 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="19"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-20"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.34-r5.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.34-r5.ebuild
new file mode 100644
index 000000000000..bb6feb7295eb
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.34-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.34-r5.ebuild,v 1.1 2010/09/15 10:06:28 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-6"
+HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.0*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}