summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-12-09 04:27:27 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-12-09 04:27:27 +0000
commit896a090e04aadaeb31a18d65c8281db466fa56b9 (patch)
treea62424ea18fcd3c58b99c937a27e623615fd1375 /sys-kernel/hardened-sources
parentBased on vanilla-2.6.32.26 + genpatches-2.6.32-28 + grsecurity-2.2.1-2.6.32.2... (diff)
downloadgentoo-2-896a090e04aadaeb31a18d65c8281db466fa56b9.tar.gz
gentoo-2-896a090e04aadaeb31a18d65c8281db466fa56b9.tar.bz2
gentoo-2-896a090e04aadaeb31a18d65c8281db466fa56b9.zip
Based on vanilla-2.6.36.1 + genpatches-2.6.36-6 + grsecurity-2.2.1-2.6.36.1-201012040057
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.36-r5.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 6c8f17c5f753..167631010aa9 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.366 2010/12/09 04:24:39 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.367 2010/12/09 04:27:27 blueness Exp $
+
+*hardened-sources-2.6.36-r5 (09 Dec 2010)
+
+ 09 Dec 2010; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.36-r5.ebuild:
+ Based on vanilla-2.6.36.1 + genpatches-2.6.36-6 +
+ grsecurity-2.2.1-2.6.36.1-201012040057
*hardened-sources-2.6.32-r30 (09 Dec 2010)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.36-r5.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r5.ebuild
new file mode 100644
index 000000000000..be9c4bad7fc8
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.36-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.36-r5.ebuild,v 1.1 2010/12/09 04:27:27 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="6"
+
+inherit kernel-2
+detect_version
+
+#HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-6"
+#HGPV_URI="mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+#SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+#UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}