summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-12 00:19:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-12 00:19:37 +0000
commitcf479c32cf263e8d4541dd72ac65e3171958ceaa (patch)
treee9b55229a7c08dede93aa867376712a0e19cb52a /sys-kernel/linux-headers
parentmerged hppa-headers back into linux-headers (diff)
downloadgentoo-2-cf479c32cf263e8d4541dd72ac65e3171958ceaa.tar.gz
gentoo-2-cf479c32cf263e8d4541dd72ac65e3171958ceaa.tar.bz2
gentoo-2-cf479c32cf263e8d4541dd72ac65e3171958ceaa.zip
merge back from hppa-headers
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.4.23_p32
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.23_p3.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.4.23_p3 b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.23_p3
new file mode 100644
index 000000000000..3ca018c85324
--- /dev/null
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.4.23_p3
@@ -0,0 +1,2 @@
+MD5 642af5ab5e1fc63685fde85e9ae601e4 linux-2.4.23.tar.bz2 29832609
+MD5 5b2115aa25f0fff7b20bdae77694f544 patch-2.4.23-pa3.gz 715860
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.23_p3.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.23_p3.ebuild
new file mode 100644
index 000000000000..e63b26ccaaf8
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.4.23_p3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.23_p3.ebuild,v 1.1 2005/01/12 00:19:37 vapier Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="headers"
+inherit kernel
+OKV="${PV/_p*/}"
+PATCH_LEVEL="${PV/${OKV}_p/}"
+KV=${OKV}-pa${PATCH_LEVEL}
+EXTRAVERSION="-pa${PATCH_LEVEL}"
+S=${WORKDIR}/linux-${KV}
+IUSE=""
+
+DESCRIPTION="Full sources for the Linux kernel with patch for hppa"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.parisc-linux.org/cvs/linux-2.4/patch-${OKV}-pa${PATCH_LEVEL}.gz"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://parisc-linux.org"
+KEYWORDS="-* hppa"
+SLOT="0"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${KV}
+ cd ${S}
+
+ einfo Applying ${OKV}-pa`echo ${PATCH_LEVEL} | awk '{ print $1 }'`
+ zcat ${DISTDIR}/patch-${OKV}-pa`echo ${PATCH_LEVEL} | awk '{ print $1 }'`.gz | patch -sp 1
+
+
+ #make sure our sources are clean
+ make mrproper
+
+ kernel_universal_unpack
+}
+
+
+src_compile() {
+
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make archdep
+
+}