summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-17 00:00:23 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-17 00:00:23 +0000
commitafb1bae2256dc5781d22703e45cb6a05c3708860 (patch)
tree275c4d7c24b50d04c63535faffdbfd87a9eb824f /sys-kernel/lolo-sources
parentfix END and OME; update savage driver (diff)
downloadgentoo-2-afb1bae2256dc5781d22703e45cb6a05c3708860.tar.gz
gentoo-2-afb1bae2256dc5781d22703e45cb6a05c3708860.tar.bz2
gentoo-2-afb1bae2256dc5781d22703e45cb6a05c3708860.zip
see the changelog
Diffstat (limited to 'sys-kernel/lolo-sources')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog24
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre12
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre1.ebuild90
3 files changed, 112 insertions, 4 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index 66ac7c2f070a..7bb0f8dada38 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,9 +1,25 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.38 2003/02/12 09:17:14 vapier Exp $
-
- TODO before gentoo-sources-2.4.20-r1:
- * Documentation
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.39 2003/02/17 00:00:23 lostlogic Exp $
+
+*lolo-sources-2.4.20.2_pre1 (16 Feb 2003)
+
+ This patchset should resolve a bunch of random stuff,
+ including some supermount issues, some hardware support
+ issues, problems related to rmapvm, and some of the
+ problems related to iptables. Test it hard, and let
+ me know what you find.
+
+ Changes from 2.4.20.1:
+ * Update base to the latest from -ck
+ * Switch to aavm from rmap
+ * Drop XFS for the moment
+ * Add a collection of patches from xfs-sources
+ * Update grsecurity
+ * Update iptables patches (this may require
+ recompiling of iptables again)
+ * Renumber things... may need to go to 3 digits
+ * Not in this set, but started working on merge of win4lin
*lolo-sources-2.4.20.1 (10 Jan 2003)
Doing things a littl different this time... people can just
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre1 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre1
new file mode 100644
index 000000000000..7c7d82917c35
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.2_pre1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 603ccbd4e92a8316b61fb21feb5964ce patches-2.4.20-lolo-r2_pre1.tar.bz2 2392107
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre1.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre1.ebuild
new file mode 100644
index 000000000000..23c08406a6c9
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.2_pre1.ebuild,v 1.1 2003/02/17 00:00:23 lostlogic Exp $
+
+IUSE="build crypt xfs"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8[7-9]*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ # This is the non-ratified xfs USE flag, enables XFS which is not
+ # patched by default because it can cause problems with JFS's
+ # journals.
+# if [ -z "`use xfs`" ]; then
+# einfo "No XFS support, is this on purpose?"
+# for file in 79*;do
+# einfo "Dropping ${file}..."
+# rm -f ${file}
+# done
+# else
+# einfo "Enabling XFS patch, are you sure you want this?"
+# fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+# [ `use xfs` ] && ewarn "XFS patches enabled, this may cause JFS problems" || \
+# einfo "XFS not enabled, is that on purpose? JFS users beware of XFS."
+
+}