summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-14 23:11:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-14 23:11:23 +0000
commit217dd626e96197fe7128887db9052aa8ce6f04a8 (patch)
tree89edfadcea4ab9419f6c33ce4067b01a9b812c36 /sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild
parentVersion bump all the way to 4.19, after reminder by bug #180147. (diff)
downloadgentoo-2-217dd626e96197fe7128887db9052aa8ce6f04a8.tar.gz
gentoo-2-217dd626e96197fe7128887db9052aa8ce6f04a8.tar.bz2
gentoo-2-217dd626e96197fe7128887db9052aa8ce6f04a8.zip
whitespace
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild44
1 files changed, 1 insertions, 43 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild
index 8eb1b346ffb2..ac57786018e7 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild,v 1.2 2007/06/26 02:54:34 mr_bones_ Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.16.47.ebuild,v 1.3 2007/07/14 23:11:23 mr_bones_ Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -13,11 +12,8 @@
# 7) Patch for Remaining Cobalt Bits (http://www.colonel-panic.org/cobalt-mips/)
# 8) Experimental patches (IP27 hacks, et al)
-
#//------------------------------------------------------------------------------
-
-
# Version Data
OKV=${PV/_/-}
GITDATE="20070415" # Date of diff between kernel.org and lmo GIT
@@ -44,7 +40,6 @@ KEYWORDS="-* mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-3.4.6"
-
# Version Control Variables
USE_RC="no" # If set to "yes", then attempt to use an RC kernel
USE_PNT="yes" # If set to "yes", then attempt to use a point-release (2.6.x.y)
@@ -65,7 +60,6 @@ SV_IP30="" # DO_IP30 == "no", IP30
SV_IP32="" # DO_IP32 == "no", IP32
SV_CBLT="" # DO_CBLT == "no", Cobalt
-
# If USE_RC == "yes", use a release candidate kernel (2.6.X-rcY)
if [ "${USE_RC}" = "yes" ]; then
KVXY="$(get_version_component_range 1-2)" # Kernel Major/Minor
@@ -89,19 +83,14 @@ if [ "${USE_PNT}" = "yes" ]; then
USE_RC="no"
fi
-
DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${STABLEVER}.tar.bz2
mirror://gentoo/mipsgit-${F_KV}-${GITDATE}.diff.bz2
mirror://gentoo/${PN}-generic_patches-${GENPATCHVER}.tar.bz2
${PATCHVER}"
-
-
#//------------------------------------------------------------------------------
-
-
# Error messages
err_only_one_mach_allowed() {
echo -e ""
@@ -136,12 +125,8 @@ err_disabled_mach() {
return 0
}
-
-
#//------------------------------------------------------------------------------
-
-
# Machine Information Messages
#
# If needing to whitespace for formatting in 'einfo', 'ewarn', or 'eerror', use
@@ -273,12 +258,8 @@ show_cobalt_info() {
echo -e ""
}
-
-
#//------------------------------------------------------------------------------
-
-
# Check our USE flags for machine-specific flags and give appropriate warnings/errors.
# Hope the user isn't crazy enough to try using combinations of these flags.
# Only use one machine-specific flag at a time for each type of desired machine-support.
@@ -345,12 +326,8 @@ pkg_setup() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
# Generic Patches - Safe to use globally
do_generic_patches() {
echo -e ""
@@ -387,7 +364,6 @@ do_generic_patches() {
eend
}
-
# NOT safe for production systems
# Use at own risk, do _not_ file bugs on effects of these patches
do_sekrit_patches() {
@@ -406,12 +382,8 @@ do_sekrit_patches() {
# /* EXPERIMENTAL - DO NOT USE IN PRODUCTION KERNELS */
}
-
-
#//------------------------------------------------------------------------------
-
-
# Exclusive Machine Patchsets
# SGI Origin (IP27)
@@ -434,7 +406,6 @@ do_ip28_support() {
epatch ${MIPS_PATCHES}/misc-2.6.17-ip28-wd93cac-tweak.patch
}
-
# SGI Octane 'Speedracer' (IP30)
do_ip30_support() {
echo -e ""
@@ -444,12 +415,8 @@ do_ip30_support() {
epatch ${MIPS_PATCHES}/misc-2.6.17-ip30-impact-vpro-mmapfix.patch
}
-
-
#//------------------------------------------------------------------------------
-
-
# Renames source trees for the few machines that we have separate patches for
rename_source_tree() {
if [ ! -z "${1}" ]; then
@@ -460,12 +427,8 @@ rename_source_tree() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
src_unpack() {
local x
@@ -473,7 +436,6 @@ src_unpack() {
mv ${WORKDIR}/linux-${STABLEVER} ${WORKDIR}/linux-${OKV}-${GITDATE}
cd ${S}
-
# If USE_RC == "yes", use a release candidate kernel (2.6.x-rcy)
# OR
# if USE_PNT == "yes", use a point-release kernel (2.6.x.y)
@@ -483,7 +445,6 @@ src_unpack() {
epatch ${WORKDIR}/patch-${OKV}
fi
-
# Update the vanilla sources with linux-mips GIT changes
echo -e ""
einfo ">>> linux-${OKV} --> linux-${OKV}-${GITDATE} patch ..."
@@ -500,12 +461,10 @@ src_unpack() {
# Patches for experimental use
do_sekrit_patches
-
# All done, resume normal portage work
kernel_universal_unpack
}
-
src_install() {
# Rename the source trees for exclusive machines
local x
@@ -529,5 +488,4 @@ pkg_postinst() {
fi
}
-
#//------------------------------------------------------------------------------