summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2012-04-11 14:35:42 +0000
committerStratos Psomadakis <psomas@gentoo.org>2012-04-11 14:35:42 +0000
commit778a308c5c1688ad8b074138eff875465b32e082 (patch)
tree017c8faf82780e0d37783ac278124aa1890e202d /sys-kernel/rt-sources
parentStable for HPPA (bug #411369). (diff)
downloadgentoo-2-778a308c5c1688ad8b074138eff875465b32e082.tar.gz
gentoo-2-778a308c5c1688ad8b074138eff875465b32e082.tar.bz2
gentoo-2-778a308c5c1688ad8b074138eff875465b32e082.zip
Version bump
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/ChangeLog7
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.2.14_p24.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index a6ddb3460d38..749d53295b96 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.13 2012/01/15 19:15:47 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.14 2012/04/11 14:35:42 psomas Exp $
+
+*rt-sources-3.2.14_p24 (11 Apr 2012)
+
+ 11 Apr 2012; <psomas@gentoo.org> +rt-sources-3.2.14_p24.ebuild:
+ Version bump
15 Jan 2012; Torsten Veller <tove@gentoo.org> rt-sources-3.0.8_p23.ebuild,
rt-sources-3.0.9_p25.ebuild, rt-sources-3.0.10_p27.ebuild,
diff --git a/sys-kernel/rt-sources/rt-sources-3.2.14_p24.ebuild b/sys-kernel/rt-sources/rt-sources-3.2.14_p24.ebuild
new file mode 100644
index 000000000000..beb14a1bf86a
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.2.14_p24.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.2.14_p24.ebuild,v 1.1 2012/04/11 14:35:42 psomas Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".gz"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+
+CKV="$(get_version_component_range 1-3)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+RT_PATCHSET="${PV/*_p}"
+RT_KERNEL="${PV/_p[0-9]*}"
+RT_KERNEL="${RT_KERNEL/_/-}"
+RT_FILE="patch-${RT_KERNEL}-rt${RT_PATCHSET}.patch${COMPRESSTYPE}"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${KV_MAJOR}.${KV_MINOR}/${RT_FILE}"
+
+DESCRIPTION="Real-time patchset for the Linux Kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="deblob"
+
+KV_FULL="${PVR/_p/-rt}"
+EXTRAVERSION="-rt${RT_PATCHSET}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${RT_FILE}"
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."