summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-12-18 18:00:44 +0000
committerBryon Roche <kain@gentoo.org>2002-12-18 18:00:44 +0000
commit1088049984e91fc828154e1a22f848da8e740dfc (patch)
tree0ec2892b6206c8c145f070789482de15f1f172a5 /sys-kernel
parentChanged econf||die to econf (diff)
downloadgentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.tar.gz
gentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.tar.bz2
gentoo-2-1088049984e91fc828154e1a22f848da8e740dfc.zip
new PPC kernel. testing still needed
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ppc-sources/ChangeLog18
-rw-r--r--sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r22
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild44
3 files changed, 61 insertions, 3 deletions
diff --git a/sys-kernel/ppc-sources/ChangeLog b/sys-kernel/ppc-sources/ChangeLog
index e43d2262838f..8cf73d858686 100644
--- a/sys-kernel/ppc-sources/ChangeLog
+++ b/sys-kernel/ppc-sources/ChangeLog
@@ -1,14 +1,26 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ChangeLog,v 1.11 2002/12/18 00:12:48 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ChangeLog,v 1.12 2002/12/18 18:00:44 kain Exp $
+
+*ppc-sources-2.4.20-r2 (18 Dec 2002)
+
+ 18 Dec 2002; Kain <kain@kain.org> ppc-sources-2.4.20-r2 :
+
+ New PPC kernel. ext2/3 ACL & xattr patches are now included, as well as
+ freeswan and some other miscellaneous fixes. This kernel is made from
+ benh's ppc.bkbits.net linuxppc_2_4_benh tree as of changeset 1.755.
+
+ XFS is no longer included.
+ WARNING: XFS is longer included.
+ ** WARNING: XFS IS NO LONGER INCLUDED **
+
+*ppc-sources-2.4.20-r1 (10 Oct 2002)
17 Dec 2002; Brandon Low <lostlogic@gentoo.org>:
Make all kernel-sources SLOT="${KV}"
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*ppc-sources-2.4.20-r1 (10 Oct 2002)
-
10 Oct 2002; Kain <kain@kain.org> ppc-sources-2.4.20-r1 :
New PPC benh kernel + XFS. Please remember that turning on XFS is optional.
diff --git a/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r2 b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r2
new file mode 100644
index 000000000000..04d61e34f379
--- /dev/null
+++ b/sys-kernel/ppc-sources/files/digest-ppc-sources-2.4.20-r2
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 fc7cb587c76f8ee8cb5706af9cda3438 patches-2.4.20-ppc-r2.tar.bz2 498184
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild
new file mode 100644
index 000000000000..220f5e606d36
--- /dev/null
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.20-r2.ebuild,v 1.1 2002/12/18 18:00:44 kain Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://cvs.gentoo.org/~kain/ppc/patches-${KV}.tar.bz2"
+KEYWORDS="-x86 ~ppc -sparc -alpha -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC
+ [ `use crypt` ] || rm 3*
+
+ kernel_src_unpack
+
+ [ `use xfs` ] && ewarn "XFS is no longer included!"
+}