summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-01-12 16:35:22 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-01-12 16:35:22 +0000
commit1faf663a00a42283025e5d461ab6099c222f0bb9 (patch)
treef1f763d5d327cd7dbf1a340f617b1a4f922594b9 /sys-kernel
parentFix invalid use of autotools-utils.eclass. (diff)
downloadgentoo-2-1faf663a00a42283025e5d461ab6099c222f0bb9.tar.gz
gentoo-2-1faf663a00a42283025e5d461ab6099c222f0bb9.tar.bz2
gentoo-2-1faf663a00a42283025e5d461ab6099c222f0bb9.zip
sys-kernel/dracut-014: Fixed bug #396575 and revbumped to r1.
Fixed fsck usage error on /usr mount wrt bug #396575. (Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/dracut/ChangeLog8
-rw-r--r--sys-kernel/dracut/dracut-014-r1.ebuild224
-rw-r--r--sys-kernel/dracut/files/dracut-014-usrmount-fsck-fix.patch45
3 files changed, 276 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index b4c0a2007932..fb59c93571f7 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.39 2012/01/11 09:58:12 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.40 2012/01/12 16:35:22 aidecoe Exp $
+
+*dracut-014-r1 (12 Jan 2012)
+
+ 12 Jan 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-014-r1.ebuild,
+ +files/dracut-014-usrmount-fsck-fix.patch:
+ Fixed fsck usage error on /usr mount wrt bug #396575.
11 Jan 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-010-r3.ebuild,
+files/dracut-010-empty-etc-ld.so.conf.d.patch,
diff --git a/sys-kernel/dracut/dracut-014-r1.ebuild b/sys-kernel/dracut/dracut-014-r1.ebuild
new file mode 100644
index 000000000000..429d8bdb7530
--- /dev/null
+++ b/sys-kernel/dracut/dracut-014-r1.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-014-r1.ebuild,v 1.1 2012/01/12 16:35:22 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+REQUIRED_USE="dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ "
+
+BASIC_MODULES="
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ "
+NETWORK_MODULES="
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug selinux ${IUSE_DRACUT_MODULES}"
+RESTRICT="test"
+
+NETWORK_DEPS=">=net-misc/dhcp-4.2.1-r1 sys-apps/iproute2"
+DM_DEPS="|| ( sys-fs/device-mapper >=sys-fs/lvm2-2.02.33 )"
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=app-shells/dash-0.5.4.11
+ >=sys-apps/baselayout-1.12.14-r1
+ >=sys-apps/module-init-tools-3.8
+ >=sys-apps/sysvinit-2.87-r3
+ >=sys-apps/util-linux-2.16
+ >=sys-fs/udev-164
+ app-arch/cpio
+
+ debug? ( dev-util/strace )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_crypt? ( sys-fs/cryptsetup ${DM_DEPS} )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools ${DM_DEPS} )
+ dracut_modules_dmsquash-live? ( ${DM_DEPS} )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 ${NETWORK_DEPS} )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( sys-fs/mdadm )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd ${NETWORK_DEPS} )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind ${NETWORK_DEPS} )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local m
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm -rf "${modules_dir}"/$m
+ else
+ rm -rf "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+# Displays Gentoo Base System major release number
+base_sys_maj_ver() {
+ local line
+
+ read line < /etc/gentoo-release
+ line=${line##* }
+ echo "${line%%.*}"
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-multipath-udev-rules.patch"
+ epatch "${FILESDIR}/${P}-usrmount-fsck-fix.patch"
+}
+
+src_compile() {
+ emake WITH_SWITCH_ROOT=0
+}
+
+src_install() {
+ emake WITH_SWITCH_ROOT=0 \
+ prefix=/usr sysconfdir=/etc DESTDIR="${D}" \
+ install
+
+ local gen2conf
+
+ dodir /var/lib/dracut/overlay
+ dodoc HACKING TODO AUTHORS NEWS README*
+
+ case "$(base_sys_maj_ver)" in
+ 1) gen2conf=gentoo.conf ;;
+ 2) gen2conf=gentoo-openrc.conf ;;
+ *) die "Expected ver. 1 or 2 of Gentoo Base System (/etc/gentoo-release)."
+ esac
+
+ insinto /etc/dracut.conf.d
+ newins dracut.conf.d/${gen2conf}.example ${gen2conf}
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D}/usr/lib/dracut/modules.d"
+
+ echo "${PF}" > "${modules_dir}"/10rpmversion/dracut-version \
+ || die 'dracut-version failed'
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ ! any_module ${DM_MODULES} && rm_module 90dm
+ ! any_module ${NETWORK_MODULES} && rm_module 45ifcfg 40network
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 00bootchart 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ elog 'To generate the initramfs:'
+ elog ' # mount /boot (if necessary)'
+ elog ' # dracut "" <kernel-version>'
+ elog ''
+ elog 'For command line documentation see dracut.kernel(7).'
+ elog ''
+ elog 'Simple example to select root and resume partition:'
+ elog ' root=/dev/sda1 resume=/dev/sda2'
+ elog ''
+ elog 'The default config (in /etc/dracut.conf) is very minimal and is highly'
+ elog 'recommended you adjust based on your needs. To include only dracut'
+ elog 'modules and kernel drivers for this system, use the "-H" option.'
+ elog 'Some modules need to be explicitly added with "-a" option even if'
+ elog 'required tools are installed.'
+ echo
+ elog 'Options (documented in dracut.kernel(7)) have new format since'
+ elog 'version 008. Old format is preserved, but will be removed in future.'
+ elog 'Please migrate to the new one.'
+ echo
+ elog 'Some dependencies were removed, because they are optional. dracut'
+ elog "will inform you with a warning when you're lacking something optional."
+}
diff --git a/sys-kernel/dracut/files/dracut-014-usrmount-fsck-fix.patch b/sys-kernel/dracut/files/dracut-014-usrmount-fsck-fix.patch
new file mode 100644
index 000000000000..2ed52835a705
--- /dev/null
+++ b/sys-kernel/dracut/files/dracut-014-usrmount-fsck-fix.patch
@@ -0,0 +1,45 @@
+From 5926a2cb526f11d4a4a3cd3980e5894f8e96e615 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Thu, 12 Jan 2012 10:23:38 +0100
+Subject: [PATCH] 98usrmount: don't pass fstab fs options as fsck options
+
+For example for line in /etc/fstab:
+
+ /dev/vg/usr /usr ext4 nosuid,nodev 0 2
+
+fsck_single is called as follows:
+
+ fsck_single /dev/vg/usr ext4 nosuid,nodev
+
+and this eventually resolves to:
+
+ e2fsck -a nosuid,nodev /dev/vg/usr
+
+which causes e2fsck usage error.
+---
+ modules.d/98usrmount/mount-usr.sh | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/modules.d/98usrmount/mount-usr.sh b/modules.d/98usrmount/mount-usr.sh
+index a61f935..fc205d5 100755
+--- a/modules.d/98usrmount/mount-usr.sh
++++ b/modules.d/98usrmount/mount-usr.sh
+@@ -19,7 +19,7 @@ mount_usr()
+
+ if [ "x$_usr_found" != "x" ]; then
+ # we have to mount /usr
+- fsck_single "$_dev" "$_fs" "$_opts"
++ fsck_single "$_dev" "$_fs"
+ _ret=$?
+ echo $_ret >/run/initramfs/usr-fsck
+ if [ $_ret -ne 255 ]; then
+@@ -29,4 +29,4 @@ mount_usr()
+ fi
+ }
+
+-mount_usr
+\ No newline at end of file
++mount_usr
+--
+1.7.8.3
+