summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-06-09 12:11:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-06-09 12:11:24 +0000
commit59317af11977b16e5d8cc9bf46864240f5087f74 (patch)
tree6994e44b3fc7d6160b4739c39ddeef0c2789a08f /sys-kernel
parentBased on 3.2.19 + 4500_patch-linux-3.2.19-rsbac-1.4.6.diff (diff)
downloadgentoo-2-59317af11977b16e5d8cc9bf46864240f5087f74.tar.gz
gentoo-2-59317af11977b16e5d8cc9bf46864240f5087f74.tar.bz2
gentoo-2-59317af11977b16e5d8cc9bf46864240f5087f74.zip
Based on 3.3.8 + 4500_patch-linux-3.3.8-rsbac-1.4.6.diff
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rsbac-sources/ChangeLog7
-rw-r--r--sys-kernel/rsbac-sources/rsbac-sources-3.3.8.ebuild35
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/rsbac-sources/ChangeLog b/sys-kernel/rsbac-sources/ChangeLog
index f54dc74bdba4..088f31d16b86 100644
--- a/sys-kernel/rsbac-sources/ChangeLog
+++ b/sys-kernel/rsbac-sources/ChangeLog
@@ -1,5 +1,12 @@
+*rsbac-sources-3.3.8 (09 Jun 2012)
+
+ 09 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
+ +rsbac-sources-3.3.8.ebuild:
+ Based on 3.3.8 + 4500_patch-linux-3.3.8-rsbac-1.4.6.diff
+ 4500_patch-linux-3.3.8-rsbac-1.4.6.diff included for testing but not applied
+
*rsbac-sources-3.2.19 (09 Jun 2012)
09 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
diff --git a/sys-kernel/rsbac-sources/rsbac-sources-3.3.8.ebuild b/sys-kernel/rsbac-sources/rsbac-sources-3.3.8.ebuild
new file mode 100644
index 000000000000..3f49f05b8542
--- /dev/null
+++ b/sys-kernel/rsbac-sources/rsbac-sources-3.3.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rsbac-sources/rsbac-sources-3.3.8.ebuild,v 1.1 2012/06/09 12:11:24 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="9"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/rsbac-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/rsbac-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch 4520_pax-linux-3.3.7-test18.patch"
+
+DESCRIPTION="Hardened + RSBAC kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ ewarn
+ ewarn "Note: the pax patches have not been applied however they are included"
+ ewarn "in the patchset. If you want to try to apply them, edit UNIPATCH_EXCLUDE"
+ ewarn "in this ebuild. Expect breakage ;)"
+ ewarn
+}