summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-10 02:53:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-10 02:53:43 +0000
commit8c51d2397d7ec92a4a3bf3f738fad60bbe2f001b (patch)
treed33dbc47dd8358f399292562d3cacc099446af42 /sys-kernel
parentwhitespace (diff)
downloadgentoo-2-8c51d2397d7ec92a4a3bf3f738fad60bbe2f001b.tar.gz
gentoo-2-8c51d2397d7ec92a4a3bf3f738fad60bbe2f001b.tar.bz2
gentoo-2-8c51d2397d7ec92a4a3bf3f738fad60bbe2f001b.zip
whitespace
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild44
1 files changed, 1 insertions, 43 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild b/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild
index d3a0c44cbd42..534a8ec0abe0 100644
--- a/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild,v 1.1 2008/02/10 01:42:35 kumba Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.6.23.14.ebuild,v 1.2 2008/02/10 02:53:43 mr_bones_ Exp $
# INCLUDED:
# 1) linux sources from kernel.org
@@ -13,11 +12,8 @@
# 7) Patch for Remaining Cobalt Bits (http://www.colonel-panic.org/cobalt-mips/)
# 8) Experimental patches (IP27 hacks, et al)
-
#//------------------------------------------------------------------------------
-
-
# Version Data
OKV=${PV/_/-}
GITDATE="20080206" # Date of diff between kernel.org and lmo GIT
@@ -44,7 +40,6 @@ KEYWORDS="-* ~mips"
IUSE="cobalt ip27 ip28 ip30 ip32r10k"
DEPEND=">=sys-devel/gcc-4.1.1"
-
# Version Control Variables
USE_RC="no" # If set to "yes", then attempt to use an RC kernel
USE_PNT="yes" # If set to "yes", then attempt to use a point-release (2.6.x.y)
@@ -65,7 +60,6 @@ SV_IP30="" # DO_IP30 == "no", IP30
SV_IP32="" # DO_IP32 == "no", IP32
SV_CBLT="" # DO_CBLT == "no", Cobalt
-
# If USE_RC == "yes", use a release candidate kernel (2.6.X-rcY)
if [ "${USE_RC}" = "yes" ]; then
KVXY="$(get_version_component_range 1-2)" # Kernel Major/Minor
@@ -89,19 +83,14 @@ if [ "${USE_PNT}" = "yes" ]; then
USE_RC="no"
fi
-
DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${STABLEVER}.tar.bz2
mirror://gentoo/mipsgit-${F_KV}-${GITDATE}.diff.bz2
mirror://gentoo/${PN}-generic_patches-${GENPATCHVER}.tar.bz2
${PATCHVER}"
-
-
#//------------------------------------------------------------------------------
-
-
# Error/Warning messages
err_only_one_mach_allowed() {
echo -e ""
@@ -148,12 +137,8 @@ err_disabled_mach() {
return 0
}
-
-
#//------------------------------------------------------------------------------
-
-
# Machine Information Messages
#
# If needing to whitespace for formatting in 'einfo', 'ewarn', or 'eerror', use
@@ -279,12 +264,8 @@ show_cobalt_info() {
echo -e ""
}
-
-
#//------------------------------------------------------------------------------
-
-
# Check our USE flags for machine-specific flags and give appropriate warnings/errors.
# Hope the user isn't crazy enough to try using combinations of these flags.
# Only use one machine-specific flag at a time for each type of desired machine-support.
@@ -356,12 +337,8 @@ pkg_setup() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
# Generic Patches - Safe to use globally
do_generic_patches() {
echo -e ""
@@ -385,7 +362,6 @@ do_generic_patches() {
eend
}
-
# NOT safe for production systems
# Use at own risk, do _not_ file bugs on effects of these patches
do_sekrit_patches() {
@@ -404,12 +380,8 @@ do_sekrit_patches() {
# /* EXPERIMENTAL - DO NOT USE IN PRODUCTION KERNELS */
}
-
-
#//------------------------------------------------------------------------------
-
-
# Exclusive Machine Patchsets
# SGI Origin (IP27)
@@ -431,7 +403,6 @@ do_ip28_support() {
epatch ${MIPS_PATCHES}/misc-2.6.23-ip28-i2_impact-support.patch
}
-
# SGI Octane 'Speedracer' (IP30)
do_ip30_support() {
echo -e ""
@@ -441,12 +412,8 @@ do_ip30_support() {
epatch ${MIPS_PATCHES}/misc-2.6.22-ioc3-revert_commit_691cd0c.patch
}
-
-
#//------------------------------------------------------------------------------
-
-
# Renames source trees for the few machines that we have separate patches for
rename_source_tree() {
if [ ! -z "${1}" ]; then
@@ -457,12 +424,8 @@ rename_source_tree() {
fi
}
-
-
#//------------------------------------------------------------------------------
-
-
src_unpack() {
local x
@@ -470,7 +433,6 @@ src_unpack() {
mv ${WORKDIR}/linux-${STABLEVER} ${WORKDIR}/linux-${OKV}-${GITDATE}
cd ${S}
-
# If USE_RC == "yes", use a release candidate kernel (2.6.x-rcy)
# OR
# if USE_PNT == "yes", use a point-release kernel (2.6.x.y)
@@ -480,7 +442,6 @@ src_unpack() {
epatch ${WORKDIR}/patch-${OKV}
fi
-
# Update the vanilla sources with linux-mips GIT changes
echo -e ""
einfo ">>> linux-${OKV} --> linux-${OKV}-${GITDATE} patch ..."
@@ -497,12 +458,10 @@ src_unpack() {
# Patches for experimental use
do_sekrit_patches
-
# All done, resume normal portage work
kernel_universal_unpack
}
-
src_install() {
# Rename the source trees for exclusive machines
local x
@@ -526,5 +485,4 @@ pkg_postinst() {
fi
}
-
#//------------------------------------------------------------------------------